new test plan, function Bugzilla::Testopia::TestPlan->create requires a name argument, and that argument was not set

RESOLVED DUPLICATE of bug 409309

Status

RESOLVED DUPLICATE of bug 409309
11 years ago
11 years ago

People

(Reporter: pannikt, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Testopia Version 1.3

Bugzilla 3.0
Testopia Version 1.3


Reproducible: Always

Steps to Reproduce:
1. open bugzilla.
2. Open "New Plan" and put sometthing in name field, choose any Product and Type, Product Version is dimmed.
3. tap "Add" button
Actual Results:  
tr_new_plan.cgi returns "The function Bugzilla::Testopia::TestPlan->create requires a name argument, and that argument was not set."
It looks like problem in Bugzilla/Testopia/TestPlan.pm file 
in method create() arguments are incorrect, for instance:

product_id->1
author_id->1
type_id->5
default_product_version->name
name->


Should the "Product Version" be dimmed ? 


Expected Results:  
New Test Plan should be created.


New installation of bugzilla 3.0 and Testopia 1.3 beta.

Comment 1

11 years ago
Can you please confirm how this was resolved as I am getting the same error?

Comment 2

11 years ago
i had the same issue, 
see https://bugzilla.mozilla.org/show_bug.cgi?id=386038#c5

Comment 3

11 years ago
(In reply to comment #1)
> Can you please confirm how this was resolved as I am getting the same error?

It hasn't been resolved. The bug is still open.

Comment 4

11 years ago
Is there a way that I can temporarily work around this issue? I'm trying to test out Testopia and this bug is keeping me from trying it. I'm using bugzilla 3.0.2 and Testopia 1.3 beta. Thanks.

Comment 5

11 years ago
This bug describes symptoms that can have several causes. I would suggest that you chat about the problem at irc://irc.mozilla.org/testopia

Comment 6

11 years ago
The problem, for us, was a cause of using JSON version 2. The methods objToJson and autoconv are deprecated in JSON 2. Instead using "my $json = new JSON; print $json->encode(\@versions);", etc. in tr_quicksearch.cgi allows the versions list to populate correctly. Getting the version list to populate correctly is necessary as default_product_version is a required field for creating a new test plan.

The error message is so strange because of the order of the arguments to create in tr_new_plan.cgi. If $cgi->param('prod_version') returns null, because it's in the middle of the "list", perl moves 'name' => $cgi->parm('plan_name') up and everything gets out of whack. By re-arranging the arguments, you can see that prod_version is really the argument causing the problem.

We made edits to remove objToJson in tr_quicksearch.cgi, but it looks like the following files will also need to be changed:

tr_new_case.cgi
tr_query.cgi
tr_new_plan.cgi
tr_show_case.cgi
tr_show_plan.cgi

and file tr_query.cgi uses autoconv which is no longer needed.

Of course, downgrading to JSON v. 1 might have been easier, but since checksetup.pl instructs using CPAN to install JSON, I'm sure other new users might run into this same problem.

Comment 7

11 years ago
Bug 409309 is tracking the JSON problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409309
You need to log in before you can comment on or make changes to this bug.