Firefox hangs at 100% CPU when idle

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Jeroen-bart Engelen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Sometimes, for no apparent reason Firefox hangs and I need to kill the process.
It just happened when I had openend a few pages from a Google search in tabs. The pages loaded and a few seconds after they were done loading Firefox stopped responding.

I investigated with Process Explorer and noticed 1 thread that hogged all the CPU cycles: firefox.exe!jpeg_fdct_islow+0x27b1f

Below is the call stack for the thread:
firefox.exe!nsPrintOptions::GetNativeData+0x2eac7
firefox.exe!nsPrintOptions::GetNativeData+0x335ae
firefox.exe!nsPrintOptions::GetNativeData+0x26e57
firefox.exe!DeviceContextImpl::PrepareDocument+0x54fd
firefox.exe!nsFontCache::Init+0x21485
firefox.exe!nsFontCache::Init+0x1849b
firefox.exe!nsPrintOptions::GetNativeData+0x1b0a4
firefox.exe!nsPrintOptions::GetNativeData+0x1bbbf
firefox.exe!nsPrintOptions::GetNativeData+0x1b52c
firefox.exe!nsPrintOptions::GetNativeData+0x1b29e
firefox.exe!NS_RegistryGetFactory+0x17aea
firefox.exe!NS_RegistryGetFactory+0x1568c
js3250.dll!js_Invoke+0x55e
js3250.dll!js_Invoke+0x5aee
js3250.dll!js_Invoke+0x5b6
js3250.dll!js_Invoke+0x905
js3250.dll!JS_CallFunctionValue+0x1f
firefox.exe!nsPrintOptions::GetNewPrintSettings+0x5fac
firefox.exe!nsPrintOptions::GetNativeData+0x224a
firefox.exe!nsPrintOptions::GetNativeData+0x275a
firefox.exe!nsBlender::Release+0x133c3
firefox.exe+0x1012
kernel32.dll!BaseThreadInitThunk+0x12
ntdll.dll!LdrInitializeThunk+0x4d

I killed the process and started Firefox again. The crashed session was restored, so all pages I had open when the hang occured were loaded again, but this time no hang.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.



I found another report for a problem in bug #369759 (https://bugzilla.mozilla.org/show_bug.cgi?id=369759), but I never noticed any disappearance of icons and I wasn't using any javascript application actively. A javascript may have been running in the background from a website ofcourse, but I hadn't visited an obvious javascript heavy site like a Google Application or anything.

Comment 1

11 years ago
reporter: you don't have symbols for ff2, so you can't get useful, accurate, or even remotely valid stack traces using anything.

if you want to investigate hangs, you'll need to use a minefield nightly http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-3.0a7pre.en-US.win32.zip  and the symbol server http://developer.mozilla.org/en/docs/Using_the_Mozilla_symbol_server
Severity: critical → normal

Comment 2

11 years ago
what java and flash versions are you using? 

can you reproduce in Safe Mode? (http://kb.mozillazine.org/Safe_Mode)
(Reporter)

Comment 3

11 years ago
Flash: 9,0,28,0
Java: Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_09-b03)

I can't reproduce the problem at all. It just occurs randomly sometimes. I have setup the symbol server as timeless proposed, however I am not running the nightlies. The next time I see it happening I'll break into the process with WinDBG and will get the stack trace (which hopefully will be useful this time).

As soon as I find a way to repro I'll try the safe mode and try to repro in a nightly.

Comment 4

11 years ago
also upgrade java to the latest release (1.6.0 update2) and flash to 9.0.47

so we can exclude those if you get another crash
(Reporter)

Comment 5

11 years ago
The bug hasn't occurred for me for a few months now. It seems as if one of the patches since the I had the bug the last time fixed it, or maybe a dependency was updated and fixed it. In any case, it seems gone now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.