Saving CNN.com to a File Crashes Firefox on Windows

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071305 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071305 Minefield/3.0a7pre

When attempting to Save the CNN.com site to a file, on Windows, Firefox first warns that the file it is trying to download has too long of a name, and then it will crash.

Note that the name that appears in this "name is too long" dialog is *not* the name that was entered in the file picker.  The name in the File picker is: CNN.com - Breaking News, U.S., World, Weather, Entertainment & Video News.htm

But the name that appears in the dialog is far longer, you can see it in the screenshot in attachment 1 [details] [diff] [review].



Reproducible: Always

Steps to Reproduce:
1. Browse to www.cnn.com
2. Chose File->Save Page As
3. Do not change the default name in the file picker or location (I was saving to desktop since I had saved previous files there).
4. Click OK on the three spurious "name is too long" dialogs that pop up.
5. Firefox Crashes.
Actual Results:  
The download manager launches as the "name is too long" dialog appears.  The "name is too long" warning will pop up three times and then Firefox will crash.

A directory is created with the name suggested in the Filepicker and that directory contains the elements of the CNN site.  But, there is no CNN HTML page saved on the desktop.



Expected Results:  
The Site should be saved properly, with the suggested file name, no spurious error dialogs, and no crashes.

I tried this on an Intel Mac and it worked, no Linux option to try it with atm.
(Reporter)

Comment 1

12 years ago
Created attachment 272211 [details]
The "name too long" warning dialog
(Reporter)

Comment 2

12 years ago
Created attachment 272214 [details]
Dr. Watson Log from the machine with several crashes listed.
Only once talkback fired, on close.

Incident ID: 34009606
Stack Signature	ntdll.dll + 0x10f29 (0x7c910f29) de4c7ad9
Product ID	Firefox2
Build ID	2007051502
Trigger Time	2007-07-13 12:14:28.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	ntdll.dll + (00010f29)
URL visited	
User Comments	
Since Last Crash	31698 sec
Total Uptime	106933 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x10f29 (0x7c910f29)
ntdll.dll + 0x10d5c (0x7c910d5c)
msvcrt.dll + 0x1c2de (0x77bfc2de)
nsCSSCompressedDataBlock::Destroy  [mozilla/layout/style/nsCSSDataBlock.cpp, line 517]
nsCSSDeclaration::~nsCSSDeclaration  [mozilla/layout/style/nsCSSDeclaration.cpp, line 105]
nsRuleNode::~nsRuleNode  [mozilla/layout/style/nsRuleNode.cpp, line 433]
nsRuleNode::~nsRuleNode  [mozilla/layout/style/nsRuleNode.cpp, line 433]
DocumentViewerImpl::Hide  [mozilla/layout/base/nsDocumentViewer.cpp, line 2033]
nsDocShell::SetVisibility  [mozilla/docshell/base/nsDocShell.cpp, line 3782]
nsFrameList::DestroyFrames  [mozilla/layout/generic/nsFrameList.cpp, line 138]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
nsBoxFrame::Destroy  [mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1120]
ViewportFrame::Destroy  [mozilla/layout/generic/nsViewportFrame.cpp, line 67]
DocumentViewerImpl::Destroy  [mozilla/layout/base/nsDocumentViewer.cpp, line 1555]
nsDocShell::Destroy  [mozilla/docshell/base/nsDocShell.cpp, line 3529]
nsXULWindow::Destroy  [mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 514]
nsWebShellWindow::Destroy  [mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 850]
nsWebShellWindow::HandleEvent  [mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 408]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1389]
nsWindow::DispatchStandardEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1429]
nsWindow::ProcessMessage  [mozilla/widget/src/windows/nsWindow.cpp, line 4584]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1577]
USER32.dll + 0x8734 (0x7e398734)
USER32.dll + 0x8816 (0x7e398816)
USER32.dll + 0xb4c0 (0x7e39b4c0)
USER32.dll + 0xb50c (0x7e39b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0xb3f9 (0x7e39b3f9)
uxtheme.dll + 0x3c20 (0x5b193c20)
uxtheme.dll + 0x1e300 (0x5b1ae300)
uxtheme.dll + 0x1ac7 (0x5b191ac7)
uxtheme.dll + 0x1b3d (0x5b191b3d)
USER32.dll + 0xbb15 (0x7e39bb15)
nsWindow::DefaultWindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1603]
USER32.dll + 0x8734 (0x7e398734)
USER32.dll + 0x8816 (0x7e398816)
USER32.dll + 0xc63f (0x7e39c63f)
USER32.dll + 0xc665 (0x7e39c665)
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1584]
USER32.dll + 0x8734 (0x7e398734)
USER32.dll + 0x8816 (0x7e398816)
USER32.dll + 0xb4c0 (0x7e39b4c0)
USER32.dll + 0xb50c (0x7e39b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0xb903 (0x7e39b903)
uxtheme.dll + 0x2881f (0x5b1b881f)
uxtheme.dll + 0x1ac7 (0x5b191ac7)
uxtheme.dll + 0x1b3d (0x5b191b3d)
USER32.dll + 0xbb15 (0x7e39bb15)
nsWindow::DefaultWindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1603]
USER32.dll + 0x8734 (0x7e398734)
USER32.dll + 0x8816 (0x7e398816)
USER32.dll + 0xc63f (0x7e39c63f)
USER32.dll + 0xc665 (0x7e39c665)
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1584]
USER32.dll + 0x8734 (0x7e398734)
Keywords: crash
(Reporter)

Comment 4

12 years ago
Thanks Ria, that was my next question (How do I tell if I should look in Brakepad or Talkback for the crash).  I've been trying to get the .dmp file from the crash, but each time after I choose "don't send to microsoft" it gets deleted, and before that, it is locked by the OS.  Let me know if that file is needed, now that you have talkback information and I'll continue trying to get it.

However, this is very reproducible, so it might save more time and be more informative to just reproduce this on a debug build.

Either way, let me know if you need more information.
(Setting version to Trunk per comment 0;
 but you might want to change this as comment 3 seems to be 2.0 Branch...)
Version: unspecified → Trunk
I'm not able to reproduce this patch in current builds.  Are you still seeing it, Clint?
Keywords: qawanted
Clint, could you please have a look again if the crash still happens for you?

Probably related to bug 303823?
(Reporter)

Comment 8

11 years ago
Crash no longer occurs on Vista with Firefox 3 RC 1
--> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

11 years ago
Keywords: crash, qawanted
Also checked again with a too long URL since the one on CNN was shortened:
http://hskupin.info/tmp/longpath/

The warning pops-up but there is no crash with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 ID:2008051206a

Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.