keyboard navigation broken when more than one tab is open

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I would expect to be able to navigate freely in any number of tabs and find focus remains where last it was in the content, or application.
as per HTML.

open http://www.peepo.co.uk in one tab
use keyboard to navigate through say 4 links.
open another tab http://www.peepo.co.uk
use keyboard to navigate through say 4 links.
return to the first tab, and it appears that focus is retained.

BUT now try to move focus...
in fact focus is with the application, not in the content window
and when focus moves to content window it starts with first link.

This contrasts with the first case in #49 where focus is in the content window
on the link that had focus last."

also my original example:
https://bugzilla.mozilla.org/attachment.cgi?id=202809


some aspects of this bug are discussed in Bug 316191
is now broken, clues please....

Comment 1

10 years ago
What build are you seeing this in? Are you saying that the patch in bug 316191 didn't fix this issue?
(Reporter)

Comment 2

10 years ago
#1
Adam, this issue is not effected by that patch

see the response for (dupe of bug 316191) bug 323805
in particular #53.

I use the latest OS X minefield nightly when filing bugs
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-3.0a7pre.en-US.mac.dmg

in this case 16-Jul-2007 05:09   17M 
(Reporter)

Comment 3

10 years ago
hoping there might be some response within 2 months ~:"
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → All
(Reporter)

Comment 4

8 years ago
Still remains issue of how to navigate with  keyboard between tabbed windows, but that is a  separate bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.