Integrate enabling session-saving with the "quitting with multiple tabs/windows open" prompt

VERIFIED DUPLICATE of bug 383753

Status

Camino Graveyard
General
VERIFIED DUPLICATE of bug 383753
11 years ago
9 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Unassigned)

Tracking

Details

While running some tests in Minefield this afternoon, I noticed that Minefield has started prompting to enable session-saving when quitting with multiple tabs and/or windows open.

"Do you want Minefield to save your tabs [and windows] for the next time it starts?"
[ ] Do not ask next time
(Save and quit)     (Cancel) ((Quit))

(They use "tabs and windows" even when you only have windows [with no tabs] open) 

Possible issues:
* Making that alert feel overloaded and confusing

* If I enable session saving but don't check "don't show this next time" (i.e., I want session saving on, but I still want to be warned before quitting with multiple tabs or windows open--this is how I have things set, as an extra protection for slippy fingers), we'll need to keep the existing text, too.

In this case, Minefield seems to treat this as "save session one time only" (since it doesn't set their session-saving pref), whereas I'd expect selecting "Save and quit" to enable session-saving but to continue prompting me about quitting with multiple things open.  If I click don't ask again, it turns on session-saving and turns off warn when quit.

So maybe it's not a good idea, but it seemed worth discussing, so filing UNCO.
Er, the reason I found it interesting is that we'd gotten some complaints about session-saving not being on by default and people quitting only to find their tabs/windows missing on restart....

Comment 2

11 years ago
This sounds like an alternative to bug 383753, so we should consider them together.

Comment 3

10 years ago
I haven't seen any complaints about "missing" session-saving in ages; do we still think it might be a good idea to do this? Frankly, I think we should just dupe this over to bug 383753 and consolidate any changes we want to make to that dialog over there.
The more I see that sheet in Firefox, the more confusing I find it.
Duping to the bug that's actually confirmed :P but my take on this particular angle is now WONTFIX; see the first sentence of comment 3, and the fact I manage to kill saved sessions in Firefox every other time I quit due to how confusing that sheet is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383753

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.