Ctrl+Space (to start IME) can cause subsequent keypresses to behave as if Ctrl were held

UNCONFIRMED
Unassigned

Status

()

Core
Widget: Win32
UNCONFIRMED
11 years ago
6 years ago

People

(Reporter: Xuefer, Unassigned)

Tracking

({inputmethod})

Trunk
x86
Windows XP
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

i press ctrl+space but while the IME is being loaded slowly, i release space and then ctrl, and press any other a-z keys, firefox just think it's ctrl + the key i press, which is recognized as a hot key combination

Reproducible: Always

Steps to Reproduce:
1. ctrl down
2. space down
3. IME is now loading, but not finished
4. space up
5. ctrl up
6. press l
Actual Results:  
"l" key press is recognized as ctrl+l, the hotkey

Expected Results:  
"l" is buffered until IME got loaded fully, and then send to IME, or
"l" is send to IME and let IME buffer it. i'm not sure if it's the duty of IME or OS-IME-interface or whatever should handle it.

Updated

11 years ago
Summary: ctrl+space hotkey generate other hot keys wronly → Ctrl+Space (to start IME) can cause subsequent keypresses to behave as if Ctrl were held

Updated

11 years ago
Duplicate of this bug: 372559

Comment 2

11 years ago
Does this happen in a latest trunk build? http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ I'd suggest creating a new profile to tests in. http://kb.mozillazine.org/Profile_Manager
Version: unspecified → 2.0 Branch
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
i can reproduce it in 3.6.3
Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

as firefox 3.5 is faster, it happen less then before

press ctrl+space (key down + key release, i'm not holding CTRL) -> IME is showing up but delay due to first time use or disk access -> press T or W (without holding CTRL) -> firefox will react on the CTRL+T or CTRL+W hotkey while it's just a character

by reading source (which i can't do), can anyone guarantee firefox that check ctrl and key press in a atomic way? look like a race condition.

i'm sure there's no such problem with all other application i use. and none of them is GTK based. any key press after i press CTRL+space will goes to IME, or simply ignored if the IME is bad handling this case  
maybe this is a GTK issue?
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

8 years ago
Version: 2.0 Branch → 3.6 Branch
Keywords: inputmethod
Oh, this bug is similar to bug 466487 which was fixed on Fx4.

Xuefer:

Can you still reproduce this bug Fx4 or later? If so, I need to change something for nsIMM32Handler::CanOptimizeKeyAndIMEMessages() returning true.
Component: Keyboard Navigation → Widget: Win32
Product: Firefox → Core
QA Contact: keyboard.navigation → win32
Version: 3.6 Branch → Trunk

Comment 7

6 years ago
I can confirm that this bug can still be reproduced on Firefox 14.0.1 (32-bit, English version), running on Windows 7 Ultimate Service Pack 1 (x64, Simplified Chinese version).
You need to log in before you can comment on or make changes to this bug.