Firefox crashes using Sun jre 6u2 on Linux

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
11 years ago
3 years ago

People

(Reporter: KKuhlemann, Unassigned)

Tracking

({crash, qawanted, stackwanted})

Details

(Whiteboard: [closeme 2010-04-21], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6) Gecko/20070629 GranParadiso/3.0a6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6) Gecko/20070715/3.0a7

Firefox 3.0a7 crashes using the latest Sun java release 6u2. The crash appears reproducible and don't start the installed talkback.
The same java works fine in firefox 2.0.0.4, Seamonkey, Opera and Konqueror, even if I install a former version (Gran Paradiso 3.0a6) in the same location keeping my plugins folder.

Reproducible: Always

Steps to Reproduce:
1. Install the latest Firefox trunk nightly.
2. Install the Sun jre 6u2 and set a symlink to the libjavaplugin_oji.so in the  Firefox plugins folder. 
3. Run Firefox and visit http://www.heise.de/security/dienste/browsercheck/tests/java.shtml (a German browser test site with 3 java applets.
4. Firefox crashes immediatly without to start talkback.

Actual Results:  
Crash.

Expected Results:  
Firefox should run the jre and show the applets.

This is only with the new 6u2 jre, the 6u1 jre worked with the firefox 30a7 nighlies.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
If you're using trunk, Breakpad should catch the crash. http://kb.mozillazine.org/Breakpad
Component: General → Plug-ins
Keywords: crash, qawanted, stackwanted
Product: Firefox → Core
QA Contact: general → plugins
(Reporter)

Comment 2

11 years ago
I'm absolutely sure that breakpad didn't work. There was no data transfer after the crash, there was no Crash-Reports directory in my profile-folder.
There are 2 file in the minidump folder of the profile with no further information. I tried to get it with gdb, but that didn't work because the firefox-bin stops if it isn't started via the start-script.

  

Comment 3

11 years ago
Dupe of bug 386844?

Comment 4

11 years ago
I am having a similar problem with JRE 6u2 with Firefox 2.0.0.5. If I use the normal ns7 version of the plugin, Firefox recognises the plugin but doesn't use it for anything. No applets appear on any pages. If I use the ns7-gcc29 version, Firefox crashes on any page with an applet on it. JRE version 1.5 works OK.

Comment 5

9 years ago
do you still see this problem using most recent version of firefox (3.5, 3.6 or trunk build) and latest version of plugin software?
Whiteboard: [closeme 2010-04-21]

Updated

9 years ago
Component: Plug-ins → Java (Sun)
Product: Core → Plugins
QA Contact: plugins → sun-java
Version: Trunk → unspecified

Comment 6

8 years ago
Closing since now after whiteboard closeme date and no reply to last comment.

Please reopen/comment with further info, if you still see this issue with Firefox 3.6.13 or later, with a clean profile and the latest version of the plugin.

If you wish, you can also try to reproduce in Firefox 4 Beta 8 or later:
http://www.mozilla.com/en-US/firefox/all-beta.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

3 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.