Closed Bug 388257 Opened 13 years ago Closed 13 years ago

NSIS installer knows nothing about Unicode

Categories

(Toolkit :: NSIS Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 305039

People

(Reporter: utf16, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0 MEGAUPLOAD 1.0
Build Identifier: 

A non English version of Thunderbird is impossible to install unless you are keen on reading garbage.

Reproducible: Always

Steps to Reproduce:
Problem nr. 1:

1. Download a Thunderbird installer in any foreign language (Japanese, Russian, Lithuanian, Korean, Greek etc.).
2. Make sure your system locale is different from the one used for the language you just downloaded the file.
3. Run the installer.

Problem nr. 2:

When the installer asks where you want to install, type some exotic in, like "C:/Program Files/タンダбирд"

Problem nr. 3

Create a user in Windows and name it as follows: ゲストгест.
Actual Results:  
1. Depending on the language you chose, the text is presented as garbage. This is what you get if you run the Japanese installer:

Mozilla Thunderbird ‚̃ZƒbƒgƒAƒbƒv
‚±‚̃EƒBƒUƒh‚Å‚ÍMozilla Thunderbird‚̃Cƒ“ƒXƒg[ƒŒ...

2. Thunderbird installs in "C:/Program Files/".

3. Thunderbird doesn't run.

Expected Results:  
1. The text should appear correctly despite my system locale settings:

Mozilla Thunderbird のセットアップ
このウィザドではMozilla Thunderbirdのインストーレ...

Unicode is a perfect solution for this kind of problems.

2. Thunderbird should install in "C:/Program Files/タンダбирд"

3. Thunderbird should run.
Component: Installer → NSIS Installer
Product: Thunderbird → Toolkit
QA Contact: installer → installer
The plan is to solve this by switching to an MSI installer once there are resources available to do so.
Depends on: MSI
Summary: Thunderbird installer knows nothing about Unicode → NSIS installer knows nothing about Unicode
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
No longer depends on: MSI
Resolution: --- → DUPLICATE
Duplicate of bug: 305039
You need to log in before you can comment on or make changes to this bug.