All users were logged out of Bugzilla on October 13th, 2018

Error when creating profile with polish characters in 2.0.0.5

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
3 years ago

People

(Reporter: abillings, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
If I try to create a new profile in the profile manager for a pl localized Firefox 2.0.0.5 build, I receive an error stating:

[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIToolkitProfileService.createProfile]" nresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"
location: "JS frame :: chrome://mozapps/content/profile/createProfileWizard.js :: onFinish :: line 233" data: no]

If this error is dismissed, the profile can then be created and shows up in the profile wizard.

See attachment for screenshot of error.

Steps to Reproduce
1. Launch firefox with profile manager.
2. Create a new profile with a name with polish characters, such as "Domyślny użytkownik"
3. Submit the profile name

Result: Error message about creating the directory.
(Reporter)

Comment 1

11 years ago
Created attachment 272436 [details]
Profile Error Message
I think I remember you saying that this was not a recent regression on IRC, that this has happened since 2.0 or since 1.5. Am I remembering correctly?
This might be Windows only, as it WFMs on the Mac:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; pl; rv:1.8.1.5) Gecko/2007071317 Firefox/2.0.0.5
Al: this might depend on Windows locale. You were using en-US Windows with pl Firefox, weren't you?

Comment 5

11 years ago
I can confirm this bug on Windows XP en-US. Al: Did you use the same language version of Windows XP? (I think it is important.)

Comment 6

11 years ago
I can confirm the same on Windows XP en-US with Japanese version of Firefox.
I entered Japanese name for new profile: デフォルトのユーザー and I got the same error.

This is encoding differences with Windows and Firefox versions.

Comment 7

11 years ago
Created attachment 273002 [details]
Profile Error Message (WinXP en-us and Fx jp)
Can't confirm on Windows XP SP2 pl and Fx 2.0.0.5 pl.
(Reporter)

Comment 9

11 years ago
I was using en-us Windows with pl Firefox.
(Reporter)

Comment 10

11 years ago
I get this in Thunderbird too, I noticed today with 2.0.0.5 testing.

Comment 11

11 years ago
(In reply to comment #2)

I can't confirm this issue on Windows XP en-US with Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.13) Gecko/20060410 Firefox/1.0.8

I created a new profile with a name: "Domyślny użytkownik". Firefox created a directory with a name: "b0py6bng.Domyslny uzytkownik" ("ś" was changed to "s").

(Reporter)

Comment 12

11 years ago
The profile can still be created, you just get the error first.

I was using "pl" and not "pl-PL" builds. It may make a difference.
Al: pl-PL is the old-style language code, no longer used in 1.8-based builds.
(Reporter)

Comment 14

11 years ago
I'm not using pl-PL, as I said.
Phenomenon when trunk seems to be different. See Bug 390127. 

Comment 16

3 years ago
This bug is filed in a bugzilla component related to pre-Firefox code which no longer exists. I believe it is no longer relevant and I am therefore closing it INCOMPLETE.

If you believe that this bug is still valid and needs to be fixed, please reopen it and move it to the Toolkit:Startup and Profile System product/component.
No longer blocks: 1243899
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

3 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.