Bookmarks cannot be exported in a file with unicode characters

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: utf16, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0 MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0 MEGAUPLOAD 1.0

When you open the bookmarks organizer and try to export in a file with unicode characters, Firefox generates two files.

Reproducible: Always

Steps to Reproduce:
1. Open your bookmarks organizer.
2. Go to File -> Export...
3. Change the name "bookmarks.html" to "букマークス.html"
Actual Results:  
Firefox saves two files: one that actually contains all the data (_______.html) and other which is zero sized (букマークス.html).

Expected Results:  
Firefox should have saved one file with the name "букマークス.html" and correct data.

Comment 1

11 years ago
confirmed 
Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
It's unlikely that this is going to be fixed in the old bookmarks code on the branch. Does this problem occur on the trunk, with the new Places code?
Version: unspecified → 2.0 Branch
(Reporter)

Comment 3

11 years ago
Well, it seems to be fixed in Minefield v3.0a8pre, but not in Firefox v2.0.0.7
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.