please add automated way to block ads

VERIFIED INVALID

Status

()

--
enhancement
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: virtual1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I would like firefox to add a window to enter URLs from which firefox will not load objects.  SWF/shockwave embedded flash objects are high on my list.  I am currently using Page Info to identify the URLs of embedded objects and add them to my HOSTS file pointing to localhost to collapse them out, but I would like an automated way to do this.  This goan can be accomplished several ways, depending on how much work you want to go to.

Reproducible: Always

Steps to Reproduce:
when a page loads an embedded shockwave object, you cannot control-click on the object to load it in a new window. (I would call this a bug!)  Simply adding "open object in new tab/window" to that contextual menu would really help us.  Or "copy object URL" would work too.  Better still would be adding an option to add the object's URL (the domain name only) to the earlier described list of domains to not load objects to. ("adfarm.doubleclick.net" etc) Please present a warning if the domain of the embedded object is the same as the page being viewed - a very small number of ads are hosted on the same server as the page.
Actual Results:  
this would take the average user about 10 minutes to remove all the highly annoying animated ads from all their favorite pages.  It should be very easy for even new users to figure out how to use.

Expected Results:  
I have just submitted a bug report on Page Info because it seems to not list all embedded objects.  I was previously using this as a very inconvenient way of finding the url (domain) of embedded ads to host them out, but now that's not working reliably anymore so we really need this feature now.

If this is a dup it would not entirely surprise me but I did look, it's a big list. ;)  If it is a dup, please check to see if my additional/alternate ideas to solve this problem are included in the original, else please copy and paste them over so whoever works on this issue has a variety of options to meet the goal.

Comment 1

11 years ago
You can use the Adblok Plus Extension from http://addons.mozilla.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.