All windows closing & Internet exit

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Tom ODonnell, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Since the new Firefox upgrade (approx 2 weeks ago?), whenever I attempt to close a page on the internet Tab), it won't allow me to return to my previous page; instead, a window pops up & asks me if I want to "close all tabs" or cancel.  If I click "close all tabs", I lose my internet connection; if I click "cancel", Ithere is no way to go return to previous tabs.  I never had this problem up until the recent upgrade.  Is this a possible bug?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Have you upgraded from 1.5.0.x to 2.0.0.4?

What are you using to close the tab? a button or a keyboard shortcut?
Could you provide incremental steps to reproduce your problem?
(Reporter)

Comment 2

11 years ago
Yes, I'm on the most recent upgrade, which is when this began happening.  It's a window that pops up asking if I want to exit all tabs or cancel.  If I click CLOSE ALL TABS, it closes all internet connections, & I must restart.

Comment 3

11 years ago
Yes, but what button are you using?

You have to close tabs using the little X buttons on EACH tab

While if you close the browser with the main close icon (on top right of the window) and you have open tabs, it will ask you if are you sure to close all tabs and the browser...
(Reporter)

Comment 4

11 years ago
Marco, when the arrow to return to the previous page is grayed out, I have no other choice but to click on the only remaining "X" button in the upper right corner.  And when I do this, I am escorted out of the internet, & need to double-click on my browser to get back in.  This has never happened before in the 2 years since I've been on Mozilla; & it does not happen on my laptop, on which I run "the other guys" as my browser.  Does that help? 

Comment 5

11 years ago
Sorry, i can't get the point... if you could attach a screenshot with some note, will help, or incremental steps to reproduce the problem

Could you check on about:config that browser.tabs.closeButton is set to 1?

Could you try to use the browser in safe mode and report if the problem exists there? (http://kb.mozillazine.org/Safe_Mode)
Version: unspecified → 1.0 Branch
Are you on dialup or VPN, and using the Connection Manager provided in XP, by any chance?  From what I remember--and I don't have a dialup connection here to test this--one can set (through Internet Explorer) dialup/VPN connections to which to auto-connect and disconnect.
(Reporter)

Comment 7

11 years ago
Since I last emailed you, I realized the CLOSE tabs are now located underneath the toolbar - so I feel the issue has been resolved.  Thanks for the good follow-up!

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4)
> Gecko/20070515 Firefox/2.0.0.4
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4)
> Gecko/20070515 Firefox/2.0.0.4
> Since the new Firefox upgrade (approx 2 weeks ago?), whenever I attempt to
> close a page on the internet Tab), it won't allow me to return to my previous
> page; instead, a window pops up & asks me if I want to "close all tabs" or
> cancel.  If I click "close all tabs", I lose my internet connection; if I click
> "cancel", Ithere is no way to go return to previous tabs.  I never had this
> problem up until the recent upgrade.  Is this a possible bug?
> Reproducible: Always
> Steps to Reproduce:
> 1.
> 2.
> 3.

(In reply to comment #6)
> Are you on dialup or VPN, and using the Connection Manager provided in XP, by
> any chance?  From what I remember--and I don't have a dialup connection here to
> test this--one can set (through Internet Explorer) dialup/VPN connections to
> which to auto-connect and disconnect.

Tom, how does this explain that you "lose all internet connection"; was that inclusion erroneous?
(Reporter)

Comment 9

11 years ago
It was erroneous.
Thanks, that's all I needed to know!  We appreciate you reporting back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.