Create linux buildbot slave VM by copying prometheus-vm

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: joduinn, Assigned: joduinn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

To test build automation, we need a linux buildbot slave. This needs to run in a VM which contains the exact same bits as we currently use in prometheus-vm.

Once the new VM is copied and running, we can add buildbot slave config files and see what happens!
Status: NEW → ASSIGNED
OS: Mac OS X → All
Priority: -- → P2
Hardware: PC → All
I'd like to call this VM "bld-lnx-slave01".

Comment 2

11 years ago
We've got a copy of prometheus-vm, pre-buildbot install lying around already.

If someone can redo the Buildbot install, then we don't have to take downtime to do this.
OS: All → Mac OS X
Priority: P2 → --
Hardware: All → PC
If you can tell me where to find "copy of prometheus-vm", I'd be happy to deal with cleaning up the buildbot install...

OS: Mac OS X → Linux
Assignee: build → joduinn
Status: ASSIGNED → NEW
Priority: -- → P2
Assignee: joduinn → rhelmer
Whiteboard: ETA July 17th
"staging-prometheus-vm" installed as per irc discussion about hostnames.

Buildbot is not set up, instructions for linux are at:
http://wiki.mozilla.org/ReferencePlatforms/BuildBot/Linux
Assignee: rhelmer → joduinn
Whiteboard: ETA July 17th
staging-prometheus-vm.build.mozilla.org is up and running, connecting to staging-build-console, and returning successful jobs. This is a new clean clone of prometheus-vm, the current 1.8 production environment.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.