Closed Bug 388337 Opened 15 years ago Closed 15 years ago

Pasting a folder which contains sub-folders fails

Categories

(Firefox :: Bookmarks & History, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 3 alpha7

People

(Reporter: mano, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
The core of this fix is this->self in the scoped functions, but I couldn't help cleaning up the new JSON code a little.
Attachment #272536 - Flags: review?(sspitzer)
(In reply to comment #0)
> Created an attachment (id=272536) [details]
> patch
> 
> The core of this fix is this->self in the scoped functions, but I couldn't help
> cleaning up the new JSON code a little.
> 

Note - inside _getFolderCopyTransaction, create______ transactions need to use index, not aIndex - otherwise copying folders can cause its children to be reversed.
And out of curiosity - should else ifs generally not be used?
not after a return statement
Comment on attachment 272536 [details] [diff] [review]
patch

r=sspitzer
Attachment #272536 - Flags: review?(sspitzer) → review+
> Note - inside _getFolderCopyTransaction, create______ transactions need to use
> index, not aIndex - otherwise copying folders can cause its children to be
> reversed.

Christine, is that problem introduced with Mano's patch, or a bug with the existing code?
By Mano's patch... just from another bug :-/

I will fix that separately.
Status: NEW → ASSIGNED
Blocks: 364298
Assignee: nobody → mano
Status: ASSIGNED → NEW
Summary: Pasting a folder which container sub-folders fails → Pasting a folder which contains sub-folders fails
Attached patch v1.1Splinter Review
aIndex->index
Attachment #272536 - Attachment is obsolete: true
mozilla/browser/components/places/content/controller.js 1.171
mozilla/browser/components/places/content/utils.js 1.52
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
No longer blocks: 388329
Duplicate of this bug: 388329
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.