nsXULPopupManager.h:124: warning: ‘DirectionFromKeyCode_lr_tb’ defined but not used

RESOLVED FIXED

Status

()

--
trivial
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: mrbkap, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Created attachment 272552 [details] [diff] [review]
Fix warnings

The problem is that there are two arrays that are declared as being 'static' in a header file. This is generally incorrect and wastes space. I'm attaching a trivial patch make these 'extern' in the header file, and to define them in only one compilation unit.
Attachment #272552 - Flags: superreview?(jst)
Attachment #272552 - Flags: review?(enndeakin)
Comment on attachment 272552 [details] [diff] [review]
Fix warnings

Looks good
Attachment #272552 - Flags: review?(enndeakin) → review+

Updated

12 years ago
Attachment #272552 - Flags: superreview?(jst) → superreview+
(Reporter)

Comment 2

12 years ago
Fix checked into trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.