ANY application call to a URL or URL Link generates an error on startup

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: richcb7, Unassigned)

Tracking

2.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Turn off all browsers.  Once the browser has started this error will not repeat.

The default browser must be set to Firefox.  This only happens with Firefox.

Click on a desktop URL link or click on a application that does a URL call for the browser to open.  

An error will be displayed saying: 
   X - Windows cannot find 'http:// >Insert ANY URL you want< '.  Make sure you typed the name correctly, and then try again.

The browser will now startup and open to the URL mentioned in the above error message.

The error will not repeat as long as the default browser is running.  

Note: If one changes the default browser to IE 7.  The problem goes away!
This only happens with Firefox. 

Reproducible: Always

Steps to Reproduce:
1. Turn off all browsers.  Once the browser has started this error will not repeat.
2.The default browser must be set to Firefox.  This only happens with Firefox.
3.Click on a desktop URL link or click on a application that does a URL call for the browser to open.  
Actual Results:  
The browser will now startup and open to the URL mentioned in the above error message.

The error will not repeat as long as the default browser is running.  

Note: If one changes the default browser to IE 7.  The problem goes away!
This only happens with Firefox. 

Expected Results:  
No error message
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
Please check in Start Menu / Default Program Settings | Set Default Programs
Select Firefox from the list and choose Set this program as Default

does this makes any difference?
(Reporter)

Comment 2

11 years ago
Having Firefox as the Default browser is a REQUIREMENT!  So yes, it is default.

The problem will not happen if it is not default.

If I set IE 7 as the default browser, the error DOES NOT occur.  

It only happens if Firefox is set at the default browser.  

Steps to Reproduce:
1. Turn off all browsers.  Once the browser has started this error will not
repeat.
>>> 2.The default browser must be set to Firefox.  This only happens with Firefox.
3.Click on a desktop URL link or click on a application that does a URL call
for the browser to open.  
Please open regedit and delete the following keys
    HKEY_CLASSES_ROOT\HTTP\shell\open\ddeexec
    HKEY_CLASSES_ROOT\HTTPS\shell\open\ddeexec
i suggest you to do a backup of those keys in case something goes wrong

then please report back if it solved the problem

for future reference: bug 137363, bug 246078, bug 254525
this could be a dupe and cause a reopen of one of those
(Reporter)

Comment 4

11 years ago
Sorry, this did not solve the problem.

I opened regedit, did an export and then deleted the two keys as requested.
I restarted the computer.

Then clicked on one of the links.  

Same error nothing different.

I opened regedit and verified that the two records were indeed deleted.
(Reporter)

Comment 5

11 years ago
Additional observations:

If the Address tool bar is opened and a URL address is entered the error does not occur.  

If a URL link in an email is clicked the error does not occur.

This is following the requirements that:
1. Firefox must be the default browser.
2. All browser programs are turned off.

Comment 6

11 years ago
This bug is a dupe of so many of the same bugs it is getting crazy. I has happened for me ever since 2.0.0.0 (maybe before). 

It is most definitely NOT fixed.... Stop closing the bugs as "verified fixed"

Every other dupe (this one included) of this bug suggests deleting the ddeexec keys from the registry entries below, but this is only a temporary fix. After your Firefox installation "auto upgrades" it breaks the registry keys again!

The problem is recreated when the upgrade adds the ddeexec keys with the (default) string value of "%1",,0,0,,,,

To fix (temporary, will break again on update or reinstall), remove the ddeexec entries from the following keys:

HKCR\HTTP\shell\open
HKCR\htmlfile\shell\open
HKCR\htmlfile\shell\opennew
HKCR\ftp\shell\open
HKCR\gopher\shell\open
HKCR\https\shell\open
HKCR\FirefoxHTML\shell\open
HKCR\FirefoxURL\shell\open

(May be more keys, but this is all I could find so far)

This is a verified issue with both Windows XP and Windows Vista (all versions)


This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.