When I browse a website that loads Java it crashes, as soon as the part of the website tries to run java

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: John, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Ok, when i go to certain websites like runescape.com and others of that sort. Firefox crashes as soon as it tries to load the application itself. For example i can go to runescape.com and other sites that use Java, without it crashing, until it tries to load what is on that pages that uses Java. At first i thought it might have been a problem with Java and Firefox thinking you have a version of Java that you do not, since a similar bug has been posted about this. Everything seemed to check out fine, just in case I updated Java since I had an older version. Firefox would still crash, I went into internet options looking for something related to Java. I found that if I uncheck the box to Enable Java it will not crash, but it will not load what is trying to use Java. Also there is no problem with Flash like I have seen somebody post in a comment to a similar report to this one. I have tried erasing my cookies deleting my history changing security options, and there seems to be no solution. I am not sure whether this started occurring when I updated Firefox or very soon after.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.runescape.com
2.select existing character 
3.pick the display quality (neither matter)
4.also lower on the page you can pick which Java applicate you wish to run (I have tried each of them)
5.choose a world
6. then it will start to load the game and immediately crash 
7. this happens with everything trying to use Java
Actual Results:  
Firefox would close itself out completely. I would either click start new session or resume. if I resume it would load the last thing before it did crash. if I start a new session and go back to revisit it is not stored in the cookies that I have even been there at all.

Expected Results:  
should have loaded the website without shutting itself down

I have Fasterfox which hasn't given me problems before
I have VideoDownloader which also hasn't given me problems
After this incident started occurring I have gotten a new them and Tor
I have the latest Firefox browser and Java plugin for Firefox
 
about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging

I also don't get any error reports or notification of why it suddenly crashes. It just goes completely down
(Reporter)

Updated

11 years ago
Keywords: crash

Comment 1

11 years ago
what version of java? (you can see that in about:plugins)
Have you tried to upgrade to latest java 1.6.0 update2?
(Reporter)

Comment 2

11 years ago
Today Firefox Updated to 2.0.0.5 and loading website with java is no longer a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

11 years ago
oh and I hate to post twice but yes I have "Java Plug-in 1.6.0_02" not that it matters for me any more, but if this is still a problem for somebody else this maybe the solution

Updated

11 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.