All users were logged out of Bugzilla on October 13th, 2018

Quicktime plugin crashes Firefox if type-Attribute is not set

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Florian, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

I was trying to integrate a Video into a Blog with the embed-Tag. I initially omitted to set the type="video/quicktime" attribute. When i was trying to see the Website, my Firefox crashed. The windows-Version is not affected by this bug. 
I'm using an Intel-Mac. If it's of interest I can have a look, if this happens on PowerPC Macs as well.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.heller-web.net/specials/movbug.html
2.
3.
Actual Results:  
Firefox Crashed

Expected Results:  
The movie should be played

I'm using an Intel-Mac. If it's of interest I can have a look, if this happens on PowerPC Macs as well.

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

I can't reproduce using QuickTime 7.0.4. When you say "crash" do you mean Firefox disappears and the Apple Crash Reporter appears or that Firefox just hangs (beachballs)?

Also, what version of QuickTime are you using? You can go to about:plugins in the URL bar to see.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.8 Branch

Comment 2

11 years ago
Works for me, Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
QuickTime 7.2.0
(Reporter)

Comment 3

11 years ago
Created attachment 272852 [details]
Error message of the Apple Crash Reporter
(Reporter)

Comment 4

11 years ago
I'm using QuickTime 7.0.4

When it crashes, the Apple Crash Reporter appears. 
I attached a screenshot of the message.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
No bug or patched referenced as the fix.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.