Closed Bug 388591 Opened 13 years ago Closed 9 years ago

reftests/bugs/368020-5.html failing on qm-centos5-01

Categories

(Core :: Layout, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: rcampbell, Assigned: karlt)

References

()

Details

Attachments

(2 files)

Re-enabled bitstream vera family of fonts and now this bug is failing on qm-centos5-01. See log (search for UNEXPECTED FAIL to find it).
roc said he had no idea why this is failing. I think we should mark it as a known fail and reference this bug.
Version: unspecified → Trunk
I've looked at the test, and it seems to be just fine; there don't appear to be any lurking rounding problems.  I don't know what's causing the odd results here.  The only thing I can think of is that somehow we're ending up with a fractional line-height on Linux, or something like that.
Version: Trunk → unspecified
Let's mark it expected-fail. Karl might be able to track this down.
Mark random as discussed in irc.
Attached image One image
(can't remember which is from -ref)
Attachment #275386 - Attachment description: One images → One image
I can't reproduce here, but the font looks quite different here.
The closest I can get is with hintstyle hintslight and Bitstream Vera Sans but I can't get the large gap between the b and the l, and grid-fitting is still different.  Reproducing may require the same version of freetype and Bitstream Vera.
Assignee: nobody → karlt
This is now passing:
http://hg.mozilla.org/mozilla-central/rev/249736790b17
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.