Closed Bug 388646 Opened 13 years ago Closed 13 years ago

Resizers shown for non-editable elements when document contains contenteditable element

Categories

(Core :: DOM: Editor, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: smaug)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached file testcase
See testcase, when clicking on any of the elements beneath the text, you should not expect to see resizers appearing, because they are not editable elements.

(note to self: the context menu issue is bug 386729)
Related to this bug; I assume that resizers don't disappear when setting 
contenteditable to false on an abs.positioned element which has focus.
nsHTMLEditor::CheckSelectionStateForAnonymousButtons should probably 
check whether element is editable and if not, hide resizers and grabber.
Assignee: nobody → Olli.Pettay
Attached patch possible patchSplinter Review
Attachment #272972 - Flags: superreview?(peterv)
Attachment #272972 - Flags: review?(peterv)
Attachment #272972 - Flags: superreview?(peterv)
Attachment #272972 - Flags: superreview+
Attachment #272972 - Flags: review?(peterv)
Attachment #272972 - Flags: review+
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.