If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Support CAPAB IDENTIFY-MSG as used on freenode

RESOLVED DUPLICATE of bug 687798

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED DUPLICATE of bug 687798
10 years ago
3 years ago

People

(Reporter: John L. Villalovos, Assigned: Glen Mailer)

Tracking

(Blocks: 2 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.84], URL)

Attachments

(2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2
Build Identifier: 

http://freenode.net/news-2003-05-19.shtml

irc.freenode.net have a feature/capability called 'CAPAB IDENTIFY-MSG'.  The
identify-msg capability causes the first character of a msg or notice to be set
to a + if the user is identified with nickserve and a - if not.

This can work right now by doing a: /quote capab identify-msg
On the server and you can see what happens.  A channel with lots and lots of
activity to see this in action is irc://irc.freenode.net/ubuntu

Unfortunately this seems to break use of: /me action

So my request for enhancement is the ability of Chatzilla to take advantage of
this capability and color the display differently depending on if a user is
identified or not identified.

Thanks,
John


Reproducible: Didn't try
(Reporter)

Comment 1

10 years ago
Here is a script for irssi which adds support for this feature.  Not sure if it would help someone implement it or not.

http://web.archive.org/web/20040604065734/http://svn.ben.reser.org/format_identify/releases/current/format_identify.pl

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Version: unspecified → Trunk

Updated

10 years ago
Blocks: 331051
(Assignee)

Comment 2

9 years ago
Created attachment 333641 [details] [diff] [review]
handle identify-msg without breaking

I had to implement this in irc.js as handler.js was too far up the event propagation tree to do this remotely neatly.

This patch merely fixes the broken ctcp ACTION messages by stripping the +/- off the message and setting the property "identifiedMessage" on the event.

This property is not currently displayed in any way (so I suppose there's not much point in turning it on actually...)

I cant remember how we decided this should be displayed after discussing it on IRC, if anyone has any suggestions, feel free to mention them.
Assignee: rginda → glenjamin+bmo
Status: NEW → ASSIGNED
Attachment #333641 - Flags: review?(silver)

Updated

9 years ago
Attachment #333641 - Flags: review?(silver) → review+

Comment 3

9 years ago
Comment on attachment 333641 [details] [diff] [review]
handle identify-msg without breaking

You use capab.identifyMsg and e.identifiedMessage; I'd prefer these to have the same name. Otherwise, it looks fine.
(Assignee)

Comment 4

9 years ago
Created attachment 339677 [details] [diff] [review]
[checked in] consistent variable names
Attachment #333641 - Attachment is obsolete: true

Updated

9 years ago
Attachment #339677 - Attachment description: consistent variable names → [checked in] consistent variable names
Attachment #339677 - Attachment is obsolete: true

Updated

9 years ago
Summary: RFE: Add support for CAPAB IDENTIFY-MSG as used on irc.freenode.net → Support CAPAB IDENTIFY-MSG as used on freenode
Whiteboard: [cz-0.9.84]
freenode now uses CAP REQ instead of CAPAB, as of the upgrade to ircd-seven. Should this bug be morphed into "support CAP REQ IDENTIFY-MSG", or should that be a new bug?
Blocks: 687798
identify-msg has been deprecated for the new account-notify capability. Should this bug be WONTFIXed?

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687798
You need to log in before you can comment on or make changes to this bug.