Sunbird L10n tinderbox fails to checkout locales due to missing permissions

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: ssitter, Assigned: ssitter)

Tracking

Details

Attachments

(3 attachments)

(Assignee)

Description

11 years ago
Sunbird L10n tinderbox fails to checkout locales due to missing permissions. All Trunk and MOZILLA_1_8_BRANCH seem effected. This makes the compare-locals results unusable.

http://tinderbox.mozilla.org/Mozilla-l10n/
http://tinderbox.mozilla.org/Mozilla1.8-l10n/

From the logfiles:

cvs -q -z 3 -d :ext:cltbld@cvs.mozilla.org:/l10n co -P -r MOZILLA_1_8_BRANCH l10n/ca/calendar [...] l10n/zh-CN/toolkit

Permission denied (publickey,gssapi-with-mic).

cvs [checkout aborted]: end of file from server (consult above messages if any)
Assignee: server-ops → aravind

Comment 1

11 years ago
(In reply to comment #0)

> cvs -q -z 3 -d :ext:cltbld@cvs.mozilla.org:/l10n co -P -r MOZILLA_1_8_BRANCH
> l10n/ca/calendar [...] l10n/zh-CN/toolkit

You should be using the calbld user for this, not the cltbld account.

This is likely failing because you don't have cltbld's key (which is by design).

Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

11 years ago
(In reply to comment #1)

Ok. From the cvs logs it seems that ccooper switched the L10n tinderbox configuration from cltbld to calbld on 10-Jul-2007 <http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=&branchtype=match&dir=mozilla%2Ftools%2Ftinderbox-configs%2Fsunbird&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-07-01&maxdate=2007-07-20&cvsroot=%2Fcvsroot>

Wondering why they still use cltbld I searched for it and found corresponding entries in the mozconfig files:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/linux/mozconfig&rev=l10n&mark=9
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/win32/mozconfig&rev=l10n&mark=10
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/linux/mozconfig&rev=MOZILLA_1_8_BRANCH_l10n&mark=9
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/win32/mozconfig&rev=MOZILLA_1_8_BRANCH_l10n&mark=10

The MacOS X tinderbox on the other side uses anonymous access:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/macosx/mozconfig&rev=l10n&mark=9
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/macosx/mozconfig&rev=MOZILLA_1_8_BRANCH_l10n&mark=9

So we either need to change the config to calbld user or anonymous user.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Updated

11 years ago
Assignee: aravind → nobody
Status: REOPENED → NEW
Component: Server Operations: Tinderbox Maintenance → Build Config
Product: mozilla.org → Calendar
QA Contact: justin → build
Version: other → unspecified
(Assignee)

Comment 3

11 years ago
Created attachment 273127 [details] [diff] [review]
tinderbox config change for "l10n" branch

If anonymous access works on the MacOS X L10n tinderbox it will hopefully also work on the Linux and Win32 tinderbox.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #273127 - Flags: review?(daniel.boelzle)
(Assignee)

Comment 4

11 years ago
Created attachment 273128 [details] [diff] [review]
tinderbox config change for "MOZILLA_1_8_BRANCH_l10n" branch

If anonymous access works on the MacOS X L10n tinderbox it will hopefully also work on the Linux and Win32 tinderbox.
Attachment #273128 - Flags: review?(daniel.boelzle)

Comment 5

11 years ago
(In reply to comment #3)
> If anonymous access works on the MacOS X L10n tinderbox it will hopefully also
> work on the Linux and Win32 tinderbox.
...assuming there is an entry in .cvspass

Comment 6

11 years ago
Comment on attachment 273127 [details] [diff] [review]
tinderbox config change for "l10n" branch

Let's try anonymous checkout; checked in on l10n.
Attachment #273127 - Flags: review?(daniel.boelzle) → review+

Comment 7

11 years ago
Comment on attachment 273128 [details] [diff] [review]
tinderbox config change for "MOZILLA_1_8_BRANCH_l10n" branch

Let's try anonymous checkout; checked in on MOZILLA_1_8_BRANCH_l10n.
Attachment #273128 - Flags: review?(daniel.boelzle) → review+
(Assignee)

Comment 8

11 years ago
Doesn't seem to work either, now the checkout fails with error:

    cvs [checkout aborted]: connect to cvs.mozilla.org(63.245.208.155):
    2401 failed: Connection timed out

I found another place where MacOS X uses anonymous access:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/macosx/tinder-config.pl&rev=l10n&mark=149#140

while Linux and Windows use calbld user:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/linux/tinder-config.pl&rev=l10n&mark=145#137
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/tools/tinderbox-configs/sunbird/win32/tinder-config.pl&rev=l10n&mark=158#150

Seems that lilmatt changed the Mac OS X L10n tinderbox config with Bug 374042.
(Assignee)

Comment 9

11 years ago
Created attachment 273231 [details] [diff] [review]
another tinderbox config change for "l10n" and "MOZILLA_1_8_BRANCH_l10n" branch

This also ports the tinder-config.pl changes from Mac OS X to Win32/Linux tinderbox.
Attachment #273231 - Flags: review?(daniel.boelzle)
Comment on attachment 273231 [details] [diff] [review]
another tinderbox config change for "l10n" and "MOZILLA_1_8_BRANCH_l10n" branch

Since anonymous checkout does not seem to work, why would we want that?

I've switched the mozconfigs to calbld user on both l10n and MOZILLA_1_8_BRANCH_l10n.
Attachment #273231 - Flags: review?(daniel.boelzle) → review-

Updated

11 years ago
Attachment #273127 - Flags: review+ → review-

Updated

11 years ago
Attachment #273128 - Flags: review+ → review-
(Assignee)

Comment 11

11 years ago
Seems that it is partly working now:

MacOSX Darwin 8.8.1 cb-xserve03 Clobber Sb-Moz1.8-l10n: Checkout FAILS
    cvs [checkout aborted]: connect to cvs.mozilla.org(63.245.208.155):
    2401 failed: Operation timed out

WINNT 5.2 solaria Clobber Sb-Moz1.8-l10n: Checkout Ok, Upload FAILS
Linux lt18-linux-tbox Clobber Sb-Moz1.8-l10n: Checkout Ok, Upload FAILS
    Last build on <http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-mozilla1.8-l10n/> is dated back to 10-Jul

Log file states "Permission denied" for upload to "calbld@stage.mozilla.org:/home/ftp/pub/calendar/sunbird/nightly/latest-mozilla1.8-l10n/".

Trunk tinderboxen also don't work properly.

Could you check if the macosx config needs to be changed from anonymous access to calbld user too?

Could you check the permissions for calbld on stage.mozilla.org please?
You'll want server-ops in the loop here if you do need permissions changes on stage.
zach, can you look into the permission issues?
(Assignee)

Comment 14

11 years ago
(In reply to comment #12)

Chris, I just saw that you partly changed the MacOs X tinderboxen from anonymous CVS access to access via calbld user. This seems to be the cause for the checkout error mentioned in Comment #11. 

Now the corresponding mozconfig entries for LOCALES_CVSROOT also needs to be updated to use calbld.
(Assignee)

Comment 15

11 years ago
Daniel, could you apply the changes from Comment #10 to the macosx tinderbox too?

Comment 16

11 years ago
There were a bunch of files in /calendar/sunbird/nightly/latest-mozilla1.8-l10n that were in group mozilla. I just adjusted the permissions for everything in that directory so the calbld user can write to them, so the stage permission errors should be gone now. 
(In reply to comment #15)
Switched the MacOSX mozconfigs to calbld on l10n and MOZILLA_1_8_BRANCH_l10n.
In sunbird/linux/tinder-config.pl following has to be changed to avoid an error:

%WGetFiles = (
"http://stage.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/sunbird-%version%.en-US.linux-i686.tar.bz2" =>
"/builds/tinderbox/Sb-Trunk-l10n/Linux_2.6.9-42.ELsmp_Depend/sunbird.tar.bz2"
);

to

"http://stage.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/sunbird-%version%.en-US.linux-i686.tar.bz2" =>
"/builds/tinderbox/Sb-Trunk-l10n/Linux_2.6.9-42.ELsmp_Clobber/sunbird.tar.bz2"
);

and

$BuildLocalesArgs = "ZIP_IN=/builds/tinderbox/Sb-Trunk-l10n/Linux_2.6.9-42.ELsmp_Depend/sunbird.tar.bz2";

to

$BuildLocalesArgs = "ZIP_IN=/builds/tinderbox/Sb-Trunk-l10n/Linux_2.6.9-42.ELsmp_Clobber/sunbird.tar.bz2";
I filed bug 389852 for the issue mentioned in comment#18.

This bug seems to be fixed except some permission problems on stage (maybe they are normal).

Comment 20

11 years ago
I attempted earlier (see comment#16) to fix the permission problems on stage. Are there still problems? If so, what are they?
Zach, look at the end of some build logs, e.g. http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-l10n/1185555106.10213.gz and http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla1.8-l10n/1185553259.6921.gz.
There is a line with "command failed!" after many "Operation not permitted" lines.

Comment 22

11 years ago
More aggressive chmod'ing tactics have been employed; let me know if it keeps happening and I'll pull out my ray gun on it.
(Assignee)

Comment 23

11 years ago
Zach, it looks like there are still some permission issues regarding upload to 
/home/ftp/pub/calendar/sunbird/tinderbox-builds/latest-trunk-l10n/ and
/home/ftp/pub/calendar/sunbird/tinderbox-builds/latest-mozilla1.8-l10n/


The checkout issue is fixed and upload to 
 /home/ftp/pub/calendar/sunbird/nightly/latest-trunk-l10n/ and 
 /home/ftp/pub/calendar/sunbird/nightly/latest-mozilla1.8-l10n/ 
seems to work fine -> resolving FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED

Comment 24

11 years ago
(In reply to comment #22)
> More aggressive chmod'ing tactics have been employed; let me know if it keeps
> happening and I'll pull out my ray gun on it.
> 

IMHO, we should rather go for a "chown -R calbld" in calendar/*/tinderbox-build if not in the whole calendar tree.
You need to log in before you can comment on or make changes to this bug.