investigate mozilla/js/rhino/mozilla/js/rhino/docs/RhinoDebugger.html

RESOLVED WONTFIX

Status

Webtools Graveyard
Bonsai
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: timeless, Assigned: Tara Hernandez)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
Pick the file that best matches the one you are looking for:
mozilla/js/rhino/docs/RhinoDebugger.html
mozilla/js/rhino/mozilla/js/rhino/docs/RhinoDebugger.html

gavin's profile on ohloh.net indicated he had contributed to rhino in bug 265871. a quick investigation indicated that the contribution was:
a. mis attributed
b. incorrect / buggy / wrong

the live/correct/interesting file lives here:
http://www.mozilla.org/rhino/debugger.html
http://bonsai-www.mozilla.org/cvslog.cgi?file=mozilla-org/html/rhino/RhinoDebugger.html

I think this is probably just corruption relating to files being dead and changed on branches or something.

anyway
http://bonsai.mozilla.org/cvsguess.cgi?file=RhinoDebugger.html
Pick the file that best matches the one you are looking for:
mozilla/js/rhino/docs/RhinoDebugger.html
mozilla/js/rhino/mozilla/js/rhino/docs/RhinoDebugger.html

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/rhino/mozilla/js/rhino/docs/RhinoDebugger.html&rev=&mark=#1
Invalid filename: mozilla/js/rhino/mozilla/js/rhino/docs/RhinoDebugger.html. Page configuration and help. Mail feedback to <sysadmins@mozilla.org>. 

http://bonsai.mozilla.org/rview.cgi?dir=mozilla/js/rhino
http://bonsai.mozilla.org/rview.cgi?dir=mozilla/js/rhino
show that there has never been a mozilla/ directory in rhino/

We need to figure out if this is a duplicate of a fixed bonsai bug, or if it's a real bug. tentatively filing against bonsai so QA can check for duplicates, however it's quite likely this bug should be moved to server ops and a rebuild operation should be performed on mozilla/js/rhino to clean up this stuff.

it might make sense for bonsai to have a feature where it can collect a list of all files it thinks it's managing and then check them against cvs and provide a list of ghosts.

There's a claim in cvs.mozilla.org that the real live page should be on MDC, but I can't find it, only this link back to www.mozilla.org:
http://developer.mozilla.org/en/docs/Rhino_documentation#JavaScript%20Tools
Bonsai was decommissioned, closing all remaining bugs "wontfix"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.