A:hover with image changes background colour but incorrectly sized box

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
19 years ago
17 years ago

People

(Reporter: aaron, Assigned: pierre)

Tracking

({css2, verifyme})

Trunk
css2, verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I am running Mozilla M15 under Windows NT to test my intranet Web site.

My pages use a style sheet that lights up hyperlink text with a blue background:

A:link {
  color :            #FFFF00 ; 
  background-color : transparent ; 
  text-decoration :  none ; 
}
A:hover { 
  color :            #FFFF00 ; 
  background-color : #FF0000 ; 
}
IMG {
	border-width :     0pt ;
	vertical-align :   middle ;
	background-color : transparent ;
}

Transparent GIFs that act as hypertext links also show this highlight through 
the transparency, and the effect is not too bad:

<A href="something.html"><IMG SRC="transparent.gif" ALT="Blue highlight"></A>

However, the highlight is only as big as normal text.  In M15, the width looks 
right but the height is wrong; IE5.0 (Win32) renders the highlight as intended 
(but it can't draw tables properly).  I'll add an attachment with an example.
(Reporter)

Comment 1

19 years ago
Created attachment 8536 [details]
An example
(Reporter)

Comment 2

19 years ago
Created attachment 8537 [details]
An image to accompany the previous attachment
This is per the spec. To get the effect you describe, use these styles:

:link, :link *, :visited, :visited * {
  color :            #FFFF00 ; 
  background-color : transparent ; 
  text-decoration :  none ; 
}
:link:hover, :visited:hover, 
:link:hover *, :visited:hover * { 
  color :            #FFFF00 ; 
  background-color : #FF0000 ; 
}
IMG {
	border-width :     0 ;
	vertical-align :   middle ;
}
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Keywords: css2, verifyme
OS: Windows NT → All
Hardware: PC → All
Resolution: --- → INVALID
As per meeting with ChrisD yesterday, taking QA.
QA Contact: chrisd → py8ieh=bugzilla
Reassigning to chrisd for verification, since I marked it resolved.
QA Contact: ian → chrisd
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
Reassigning to petersen for verification, since I marked it resolved.

QA Contact: ian → petersen

Comment 8

17 years ago
See also bug 85354, an evangelism bug for a similar problem.
You need to log in before you can comment on or make changes to this bug.