Closed Bug 388832 Opened 13 years ago Closed 13 years ago

Link (href tag) inside section (span tag), do not work with hebrew language

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178991

People

(Reporter: hagaigold, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

when there are few section (span tags), one after another. and in each span there is a link with description in hebrew, only the last/first link is working, other links don't work.

when all the links are in ONE big section (span tag), all is well.
when the text is not hebrew, all is well.
when i changed the direction to right-to-left (rtl), problem also solved.  

Reproducible: Always

Steps to Reproduce:
1. just look on the example i put on http://www.yogagoldi.com/bug.html
2.
3.



In IE7 & Opera 9.22 the problem don't appears.
Attached file exmpale of the problem
Summary: Link (href tag) inside section (spam tag), do not work with hebrew language → Link (href tag) inside section (span tag), do not work with hebrew language
This bug will be fixed in Firefox 3, but due to the scope of the patch that fixed it, it won't be fixed in Firefox 2.0.0.x.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 178991
You need to log in before you can comment on or make changes to this bug.