Signed email not recognized as signed by TB 2.0.0.4

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: nelson, Unassigned)

Tracking

({regression})

x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 273040 [details]
screen shot

I am reporting this problem on behalf of a Thunderbird user who wishes to 
remain anonymous.  He is running Thunderbird 2.0.0.4 (Windows/20070604)
He is able to send signed and encrypted email messages, but when he receives
a signed email message, he does not see any indicator that the mail is 
signed (either with a valid signature, or with an invalid signature).
However, he does see a mysterious red circle immediately below the 
"Get Mail" button.  

The messages he receives are complete (that is, the signature has not been 
stripped off), because he can forward them to me (as attachments), and the 
signatures are still intact in the forwarded copy.  

He is using a POP3 mail server.  

When I look at the same message in SeaMonkey, the signature indication 
appears as expected.

Comment 1

11 years ago
Created attachment 273047 [details]
screen shot with the signed icon

any chance he's not using the default theme? 

This is working for me on Windows using 2.0.0.4 for signed messages. 

It looks like a theme issue to me which made me ask.

Comment 2

11 years ago
or a bad extension. I've never seen a content-transfer-encoding header in the message header. And those boxes behind the header pane look like they are from an extension.

Comment 3

11 years ago
"I have a friend who's having this problem..." :-) It looks like someone is setting the mailnews.headers.extraExpandedHeaders pref to get the content-transfer-encoding in the message pane - an extension might do that...

Could enigmail be involved?
(Reporter)

Comment 4

11 years ago
I was told that enigmail was installed, and then uninstalled.  Might it have 
left some undesirable effects in the profile after being removed?
(Reporter)

Comment 5

11 years ago
I don't know whether any themes are involved.

Any idea about the mysterious red circle (maybe an empty notification bar?)
just below the "Get Mail" button and above the message header pane?  

Comment 6

11 years ago
Enigmail is definitely involved as it was installed PRIOR to attempting to use S/MIME.

It apparently caused problems with TB and was un-installed.  Only then, did the attempts to use S/MIME start.  It could have left footprints and settings behind which could affect user.

Themes:
I believe the theme being used is the Default theme.  That issue was addressed during initial troubleshooting steps, following same reasoning mentioned by Scott.

Also, email address is set as default.

Comment 7

11 years ago
The Red circle on the left top side comes from an add-ons (Info RSS 1.1.2). I disabled it and still have the same problem. Enigmail was install/uninstalled. 

Comment 8

11 years ago
I'd try this:

1) Uninstall thunderbird
2) Then re-install thunderbird

Sounds like enigmail may have left something behind?

Comment 9

11 years ago
Scott,

Uninstall/reinstall has already been done during basic troubleshooting.  No changes.

Perhaps creating a test profile, then trying again to receive a digitally signed email would make sense, in case Enigmail (or something else) has corrupted the current (default) profile.
(Reporter)

Comment 10

11 years ago
Stéphane, did you try a test profile?  
Did the problem appear in the test profile?

Comment 11

11 years ago
The content-transfer-encoding header seems like a left-over from Enigmail (which adds CTE  and some more fields to the pref "mailnews.headers.extraExpandedHeaders"). But other than that Enigmail does not change any settings that could disturb S/MIME.

I doubt that Enigmail would interfere with S/MIME. It seems that something is blocking the initiation or execution of the S/MIME verification. Is there any error in the Error Console?

Comment 12

10 years ago
stef_204: still see this on trunk?

http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

Without further info, this bug should be closed as INCOMPLETE.
Assignee: dveditz → nobody
(Reporter)

Comment 13

10 years ago
I thought this was resolved long ago.  Sorry. 
The person who experienced the problem, the author of comment 6 and 
comment 9, created a new profile with Enigmail uninstalled, and was 
unable to reproduce the problem.  My conclusion was that Enigmail left
his profile in some undesirable state.  In any case, the problem originally
reported here was apparently not the fault of Thunderbird.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.