paying a price for the personal toolbar, even if it is hidden

RESOLVED FIXED in Firefox 4.0b2

Status

()

defect
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: moco, Assigned: dao)

Tracking

({perf})

Trunk
Firefox 4.0b2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [ts])

Attachments

(1 attachment, 1 obsolete attachment)

paying a price (doing a query, building up results) for the personal toolbar, even if it is hidden

I found this while trying to track down some leaks for bug #387203.

need to investigate.
maybe should only init if toolbar is visible, hook into it's load/show event?

http://mxr.mozilla.org/seamonkey/source/browser/base/content/browser.js#308

also, probably shouldn't init the places folder queries either until this happens.
updated link:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#446

this is still true, even if the toolbar is hidden the place property gets set and the result is populated.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
(Assignee)

Updated

9 years ago
No longer depends on: 575532
Duplicate of this bug: 575532
(Assignee)

Comment 5

9 years ago
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #454825 - Flags: review?(mak77)
(Assignee)

Comment 6

9 years ago
Bug 528884 likely introduced this bug to popups.
Blocks: 528884
Whiteboard: [ts]
(Assignee)

Comment 7

9 years ago
Requesting blocking since the toolbar is now hidden by default.
blocking2.0: --- → ?
(Assignee)

Comment 8

9 years ago
Posted patch patchSplinter Review
updated to tip
Attachment #454825 - Attachment is obsolete: true
Attachment #457785 - Flags: review?(mano)
Attachment #457785 - Flags: review?(gavin.sharp)
Attachment #454825 - Flags: review?(mano)
Attachment #457785 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 9

9 years ago
http://hg.mozilla.org/mozilla-central/rev/7c44f05a46ae
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b2
(Assignee)

Updated

9 years ago
Attachment #457785 - Flags: review?(mano)
(Assignee)

Comment 10

9 years ago
numbers from mozilla.dev.tree-management:

Txul decrease 6.08% on MacOSX 10.6.2 Firefox
Txul decrease 3.17% on MacOSX 10.5.8 Firefox
Ts decrease 4.39% on Linux Firefox
blocking2.0: ? → final+

Updated

7 years ago
Blocks: 763622
You need to log in before you can comment on or make changes to this bug.