If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird 2.0 crash(or freeze) after bug 389139(setting Inbox folder of his own is possible)

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
critical
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Saïvann Carignan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070718 Ubuntu/7.10 (gutsy) Firefox/2.0.0.4
Build Identifier: Thunderbird 2.0.0.4

This bug has been experienced on Linux Ubuntu 7.04 and 7.10, and on Windows XP with thunderbird 2.0.0.4 . Thunderbird 3 doesn't crash but still doesn't work as expected.

Thunderbird 2 completely crashes on Windows and freezes on Linux after configuring the inbox folders of a account in the way described in the steps to reproduce or shown by this screenshot :

http://upload.leservicetechnique.com/bugs/ThunderbirdProfileBug.png

Thunderbird 3 doesn't crash but the whole account disappears from the folders when it should appear outside of the local folders


Reproducible: Always

Steps to Reproduce:
1. Create a mail account ( we will name that accound George )
2. Go to the account settings ( edit / account settings or tool / account settings )
3. Click on "server settings" for the George account
4. Click on Advanced...
5. Change "Inbox for this server's account" for "Inbox for different account"
6. At the end of the "Inbox for different account" line, choose the George account instead of Local Folders.
7. Restart Thunderbird
Actual Results:  
Thunderbird won't open sucessfully until you delete the entire profile and create another. The safe mode can't do anything around that.

Expected Results:  
Show the inbox of the account and use it like it was configured in the account settings.
(In reply to comment #0)
> Steps to Reproduce:
> 1. Create a mail account ( we will name that accound George )
>(snip)
> 5. Change "Inbox for this server's account" for "Inbox for different account"
> 6. At the end of the "Inbox for different account" line, choose the George
> account instead of Local Folders.

Following part is CONFIRMED with Tb 2.0.0.4(MS Win-XP).
  - Choosing of Inbox of myself is accepted
    even though "Inbox for different account" is selected.
This should be rejected by UI, or if not rejected by UI for definition, warning have to be issued when restart, and such account have to be ignored.
(I won't try to re-create "crash/freeze after restart" part)

> Thunderbird 2 completely crashes on Windows and freezes on Linux

What is Talkback ID of the crash?
Freeze(wait forever) when Linux? Loop isn't it?

> Thunderbird 3 doesn't crash but the whole account disappears

"account disappears" works as designed. When "Inbox for different account" is selected, Inbox of chosen Account is used, and the account who use Global Inbox(George in your case) itself is hidden.
See http://kb.mozillazine.org/Global_Inbox.
This article only describe about "Local Folders" as Global Inbox account. So replace "Local Folders" by "Not hidden account=Account who doesn't use Global Inbox" when you read.

Sorry but I don't know Tb's behavior when user chooses Inbox of other hidden account(account who uses Global Inbox), or when user chooses Inbox of myself.

Workaround.
Choose Inbox of other account instead of Inbox of myself, since you are saying you want to use Inbox of different account.
(Reporter)

Comment 2

10 years ago
> > What is Talkback ID of the crash?
> > Freeze(wait forever) when Linux? Loop isn't it?

I can't get no ID from Talkback. Thunderbird freezes on Linux but don't use 100% of the CPU. Here's what I get from thunderbird when runned on a terminal :

http://paste.ubuntu-nl.org/30552/

On Windows, windows simply says that Thunderbird has crashed and will now be closed. Once again, no TalkBack ID..

> > "account disappears" works as designed. When "Inbox for different account" is selected, Inbox of chosen Account is used, and the account who use Global Inbox(George in your case) itself is hidden.

The problem here is that George is normally configured to use is own inbox folder. Why the George inbox doesn't appear? I think that you're right, Thunderbird should not let changing the inbox folder of a account " to his own ". There's a error here.

Why I got to modify the account to use his own "inbox folder" ? Just because it seemed to be the only way I could use to check the "Include this server when getting new mail" without using the Global account. Waybe that could be a interesting future functionnality.
(In reply to comment #2)
> The problem here is that George is normally configured to use is own inbox folder.

Account of George is NEVER configured normally to use own Inbox, because you selected "Inbox for different account" option instead of "Inbox for this server's account" option.

Additional test results with Tb trunk 2007/7/17 build.

Case-1: Try to use Inbox of different(really different) account who is already set to use "Inbox for different account".
 account(who is already set "Inbox for different account") is excluded from
 account selection list for "Inbox for different account".
 => Problem will never occur
Case-2: Own Inbox is chosen from account list for "Inbox for different account" and restarted (your case)
  "Include this server when getting new mail" is unchecked always when save
  option settings of Server Settings/Advanced.
  (probably by same logic as "Inbox for this server's account" case)
  Then "Get All New Messages" and "Get Msgs(for the hidden account)" won't
  try POP3 server access.
  So severe problem such as hang/freeze/data_loss will never occur.

Only problem is that myself is not excluded from account selection list for "Inbox for different account" when Tb trunk.
I think "crash/freeze of Tb 2.0"(this bug) and "myself is not excluded" are better to be separated.
I recommend you to open a new bug for "myself is not excluded" part only. 

(Reporter)

Comment 4

10 years ago
Well I can do that but the description and the severity of the bug will be the same. You really think that I should do that?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Updated

10 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 389139
Reopening and setting dependency, because crash/freeze of Tb 2.0 is better to be resolved even when Bug 389139 is not resolved, although resolving of Bug 389139 will automatically resolve this bug.
Status: RESOLVED → UNCONFIRMED
Depends on: 389139
Resolution: DUPLICATE → ---
Summary: Thunderbird crash when setting the inbox folder of a account to his own local inbox folder. → Thunderbird 2.0 crash(or freeze) after bug 389139(setting Inbox folder of his myown is possible)
Version: unspecified → 2.0
Summary: Thunderbird 2.0 crash(or freeze) after bug 389139(setting Inbox folder of his myown is possible) → Thunderbird 2.0 crash(or freeze) after bug 389139(setting Inbox folder of his own is possible)
Saïvann, can you make this happen with a trunk build? (possibly not if you are using ubuntu)  
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

Then you can get the breakpad information from http://kb.mozillazine.org/Breakpad#Windows_2000.2FXP

** first - make a profile backup using mozbackup 

(surely Bug 389139 should not be sev=minor if it can lead to this crasher)
(Reporter)

Comment 8

10 years ago
Before I give further informations, I must notice that I CAN'T get this bug to happen again with the 2.0.0.6 release. the bug seems to have been fixed because it still happens in 2.0.0.0. The but 389139 isn't fixed but it now can't lead to a crash.

Like I said earlier :

> Thunderbird 2.0.0.0 completely crashes on Windows and freezes on Linux

> Thunderbird 3alpha1 doesn't crash on Windows or Linux

I can't get any Breakpad information because Thunderbird crash without giving any TalkBack infos or anything else, it's a dirty crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
(In reply to comment #7)
> can you make this happen with a trunk build?
> (surely Bug 389139 should not be sev=minor if it can lead to this crasher)

Bug opener reported following in comment #0. 
> Thunderbird 3 doesn't crash but still doesn't work as expected.
Bug 389139 is for the "still doesn't work as expected" part, and this bug is crash/hang of Tb 2.0 part in comment #0.

This bug has been marked FIXED(I think because no crash/hang on trunk).
Does it mean that patch for 1.8.1 branch will never be made to avoid crash in future Tb 2.0.0.x releases? (==WONTFIX for 1.8.1 branch) 
(Reporter)

Comment 10

10 years ago
I marked the bug as fixed because it's now fixed for thunderbird 2.0.0.6 and 3alpha1 . You can correct me if I do something wrong.

The bug 389139 is still not fixed.
(In reply to comment #10)
> I marked the bug as fixed
Oh, you were the person who changed to FIXED.
FIXED is used when patch which resolved problem is known. Do you know patch or bug apparently FIXED the crash/hang problem? 
In your case, problem occurred till Tb 2.0.0.0 but disappeared with Tb 2.0.0.6. So WORKSFORME is usually used. 
(Reporter)

Comment 12

10 years ago
Thanks WADA for this precision, and sorry for the mistake.
Resolution: FIXED → WORKSFORME

Updated

5 years ago
No longer depends on: 389139

Updated

5 years ago
Depends on: 389139
You need to log in before you can comment on or make changes to this bug.