No sans serif font in msg display

VERIFIED FIXED in M16

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: BenB, Assigned: nhottanscp)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Reproduce:
1. Set you font preference to sans-serif.
2. Send yourself a HTML mail with 4.x. Do not set fonts. You'll recieve a ,sg
without font tags.
3. View it with Mozilla.

Actual result:
The msg is displayed in a serif font.

Expected result:
The msg is displayed in a sans-serif font.

Comments:
Same for plain text msgs, if variable width font is selected. (The previous
tree contained the same bug for plain text msgs, which I fixed for 31906, but
this fix is now impossible due to the changes for the language sensitive fonts
bug.)
(Reporter)

Updated

18 years ago
Keywords: regression
(Assignee)

Comment 1

18 years ago
Accepting, I have a fix.
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 2

18 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

18 years ago
verified on Linux with build just built. tnx for fixing so fast.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 4

18 years ago
wait, bugzilla mails are still displayed in a serif font. They have no
content-type/charset headers. Could this also be the real reason for bug 37299?
(The latter bug is still suspicious to me, because I still think, the <pre>s
shouldn't be necessary.)

REOPENing
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

18 years ago
fixed remaining problem (bugzilla mails display)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
Verified in 9/29 build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.