checksetup.pl fails after patch on bugzilla-3.0

RESOLVED WORKSFORME

Status

Testopia
General
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Shai, Assigned: Vance Baarda)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: ubuntu 7.10 

tried dropping bz_scheme table and re run checksetup.pl as noted in the FAQ, but it didn't help

mysql 5.0 server, bugzilla 3.0, testopia 1.3-beta 


Reproducible: Always

Steps to Reproduce:
1. untar testopia-1.3-beta in bugzilla directory 
2. patch with testopia/patch-3.0
3. run ./checksetup.pl 

Actual Results:  
checksetup.pl output 

An error occurred processing hook install-update_db in
    extension ./extensions/testopia: Not a reference at Bugzilla/DB/Schema.pm line 2096.

Expected Results:  
it should work : )
(Assignee)

Comment 1

11 years ago
testopia-1.3-BETA1.tar.gz or testopia-1.3-BETA2.tar.gz?

Your Bugzilla server is ubuntu 7.10?

Please attach your copy of Bugzilla/DB/Schema.pm
(Reporter)

Comment 2

11 years ago
my bugzilla is running on Ubuntu server - feisty 64bit,
but I've cloned the data base and setup a new bugzilla before I mess with the production... 

I'm using bugzilla-3.0.tar.gz
with testopia-1.3-BETA2.tar.gz
and mysql  Ver 14.12 Distrib 5.0.38, for pc-linux-gnu (i486)
see attached Bugzilla/DB/Schema.pm
(Reporter)

Comment 3

11 years ago
Created attachment 273240 [details]
Bugzilla/DB/Schema.pm gziped
(Assignee)

Comment 4

11 years ago
Thanks -- I'll look at it on Monday.
(Assignee)

Comment 5

11 years ago
Didn't get time to look at this today -- will try again Wednesday.
(Assignee)

Updated

11 years ago
Assignee: ghendricks → vrb
(Assignee)

Comment 6

11 years ago
I can't reproduce this problem on openSUSE 10.2. Steps I took:

(created empty database)
tar xzvf bugzilla-3.0.tar.gz
cd bugzilla-3.0
vi localconfig
./checksetup.pl
vi data/params
./checksetup.pl
tar xzvf ../testopia-1.3-BETA2.tar.gz
patch -p0 -i testopia/patch-3.0
./checksetup.pl

Suggestion: restore your database and your Bugzilla docroot to the way they were before you first tried to install Testopia, then do this:

tar xzvf ../testopia-1.3-BETA2.tar.gz
patch -p0 -i testopia/patch-3.0
./checksetup.pl

If this still doesn't work, I'll need the full output from patch and from checksetup.pl.
(Assignee)

Comment 7

11 years ago
No response -- closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.