AJAX control scrolling is very choppy

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
See litmus testcase: http://litmus.mozilla.org/show_test.cgi?id=4339

Horizontal scrolling of the timeline in this testcase is very choppy on Linux.  It works fine in Windows.

Steps to reproduce:
1. Navigate to URL
2. Click and drag the timeline left or right

Actual results:
The timeline moves very choppy, if at all.  Sometimes it doesnt move until the mouse button is released.

Expected Results:
Timeline should move smoothly with the mouse.

Reproducible: Always
Windows scrolling works reasonable on trunk, but cpu is much higher as on branch, I think.
When did it regress on linux.
Did it regress between 2007-04-30 and 2007-05-01 on trunk, in that case it would be a regression of bug 368247.
Anthony: Is this still an issue ?
I can't test this on my linux box because I use VNC to access it.
Component: General → Graphics
Flags: needinfo?(anthony.s.hughes)
Product: Firefox → Core
(Reporter)

Comment 3

6 years ago
Heh, very old bug. I can no longer reproduce this, it's smooth as butter. There have been generational leaps in Firefox, Linux, and my hardware since 2007. As a result it will be impossible for me to determine who fixed what. Marking this bug resolved WORKSFORME.

Thanks for calling my attention to it, Matthias.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(anthony.s.hughes)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.