Closed Bug 389036 Opened 17 years ago Closed 17 years ago

recurring task: only first instance is shown in agenda

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sebo.moz, Assigned: sebo.moz)

References

Details

(Keywords: regression)

Attachments

(1 file)

Create an recurring task with only a start date set that recurs daily for 5 days. If the base item starts today, it is shown under "Today". The following occurrences are not shown under "Tomorrow" and "Soon". In some cases I could only reproduce this after restart.

This has been regressed by the fix in bug 332193.

Patch coming up.
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #273196 - Flags: review?(michael.buettner)
Blocks: 332193
OS: Windows XP → All
Hardware: PC → All
When I manually make these changes to agenda-tree.js and restart Thunderbird, the problem in bug 332193 returns.  (Lightning 0.7pre 2007072003)
Sorry, I meant that the problem in bug 386563 returns.
(In reply to comment #3)
> Sorry, I meant that the problem in bug 386563 returns.
> 
That is to be fixed by bug 386502. I didn't see this while testing this patch, because I had both patches applied.
I applied the patch from this bug and the patch from bug 386502 and the problems that I had are now fixed.  Thanks.

(Lightning 2007072204 / Thunderbird 2.0.0.5)
I applied both fixes and both bugs disappeared for me. 
Thanks

(Lightning 2007072203 / Thunderbird 2.0.0.5)
Linux
I actually never tested this patch with tasks.  However, this patch also fixes a problem with events.  To reproduce:

1) Stop Thunderbird, unapply this patch if you manually applied it, start TB.

2) In month view, create a weekly recurring event that started one week before tomorrow.

3) In the today pane, you see the event in "Tomorrow" (that's right).

4) Restart TB and look in the today pane again.  The event isn't there in "Tomorrow" (that's wrong).

5) Stop TB, apply this patch, restart TB, and now the event is there in "Tomorrow" (that's right).
Comment on attachment 273196 [details] [diff] [review]
Use correct operator

r=dbo; we want expanded occurrences.
Attachment #273196 - Flags: review?(michael.buettner) → review+
Keywords: checkin-needed
Checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified in Lightning build 2007080205 -> task is fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: