Wish: Password manager will not remember passowrd for specific username

RESOLVED WONTFIX

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: Dotan Cohen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

I often check my Gmail on other people's computers. Whenever I log in, I am presented to choose how I want Firefox to remember my password:
1) Never For This Site
2) Not Now
3) Cancel

I would like an option "Not for this username". As this is not my computer, I don't want to select "Never for this site" as the owner may very well want the password manager in the future. But it's annoying choosing "not now" each time. So I'd like Fx to remember that for username XXX on site YYY don't save the password, and don't ask again.

Reproducible: Always

Steps to Reproduce:
1. Go to login form on any website
2. Enter login info and click "Not Now"
3. Repeat
I don't think adding more buttons in the prompt is good idea, especially since this is an uncommon case. If you're using other computers often enough that the prompt is annoying, you might consider creating a separate Firefox profile there or use something like Portable Firefox on a USB key.

Also, Firefox 3 changes the modal prompt to a notification bar which you can just ignore.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

11 years ago
I do agree that there should not be too many buttons on the dialog box. If Fx3's behaviour is such that this will not be a problem, then as far as I'm concerned the bug is resolved. Thanks.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.