If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Visting richinstyle test page causes crash

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
critical
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Sitsofe Wheeler, Assigned: dcone (gone))

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Visit http://www.richinstyle.com/test/positioning/positionfixed3.html

Result:
Mozilla crashes.

build id: 20000510 Linux

Comment 1

18 years ago
Looks like a Linux thing.  Just visited site with M15, Mac OS 9.0.4, MRJ 2.2,

carbon libs 1.0.4.  No crash.



It *did* crash Communicator 4.72 with a Type 3 error -- figure that one out!

Comment 2

18 years ago
Doesn not crash 051210 build under NT or 98.  will try to get some confirmation
from linux testers tonight.  sitsofe@yahoo.com (Sitsofe Wheeler) can you test
with today's talkback build and report back with a crash incident.
(Reporter)

Comment 3

18 years ago
Crashed M15 Linux build. Talkback (TB10417395E) posted.

Comment 4

18 years ago
Adding crash keyword
Keywords: crash

Comment 5

18 years ago
chofmann, can you help us get any relevant info from this talkback report?

Comment 6

18 years ago
the easiest way to pull data out of the talkback database 
is by user e-mail address as submitted in the talkback
report.  just searched for reports from sitsofe@yahoo.com
and found nothing.  

lets get someone to reproduce and let me know
about something I can search for in the e-mail addr field.
(it doesn't have to be a valid e-mail address, just something
to identify)

I tried to reproduce with a recent daily build and 
it appears the link is dead.

(Reporter)

Comment 7

18 years ago
filed another talkback using my email address. Should also contain the url to
this bug. The link worked fine when I tested it.

Comment 8

18 years ago
we are struggling here...  looks like no symbols on
the talkback server to resolve the stack trace
but here we go..  If you can grab a more recent build
and try we can get some better data. Give the monday
builds a try...  thanks...

Netscape6      
Netscape LinuxIntel (2000041811) 

Incident ID 10443606 
libraptorgfx.so + 0xdd73 (0x40020d73) 
libraptorgfx.so + 0xd47e (0x4002047e) 
libraptorgfx.so + 0xd1e6 (0x400201e6) 
libraptorgfx.so + 0xd2a8 (0x400202a8) 
libraptorview.so + 0x15a9c (0x409c3a9c) 
libraptorview.so + 0x155ac (0x409c35ac) 
libraptorview.so + 0x15325 (0x409c3325) 
libraptorview.so + 0x166f0 (0x409c46f0) 
libraptorview.so + 0x787d (0x409b587d) 
libwidget_gtk.so + 0x3000a (0x413dd00a) 
libwidget_gtk.so + 0x2ff35 (0x413dcf35) 
libwidget_gtk.so + 0x33d15 (0x413e0d15) 
libwidget_gtk.so + 0x33e95 (0x413e0e95) 
libwidget_gtk.so + 0x33bd9 (0x413e0bd9) 
libglib-1.2.so.0 + 0x10ba9 (0x405b3ba9) 
libglib-1.2.so.0 + 0xfbe6 (0x405b2be6) 
libglib-1.2.so.0 + 0x101a1 (0x405b31a1) 
libglib-1.2.so.0 + 0x10341 (0x405b3341) 
libgtk-1.2.so.0 + 0x8c209 (0x404da209) 
libwidget_gtk.so + 0x22e1a (0x413cfe1a) 
libnsappshell.so + 0x1463a (0x40fc263a) 
mozilla-bin + 0x320c (0x0804b20c) 
mozilla-bin + 0x3523 (0x0804b523) 
libc.so.6 + 0x181eb (0x402f81eb) 

Comment 9

18 years ago
page seems to be loading fine for me on win32 (win95)
using a release build from this morning.
(Reporter)

Comment 10

18 years ago
I now see why I see the crash. I use a remote X session to use moz normally (PC
- sparc). I tested on the same linux box locally and the crash did not appear.

Comment 11

18 years ago
work for me  win98 SE #2000053020

Comment 12

18 years ago
Sitsofe, should this be resolved WORKSFORME?
(Reporter)

Comment 13

18 years ago
I don't think it's fair to mark this worksforme becuase it DOES happen (repeated
in a 052120 Linux build). The only justification for marking this worksforme is
that I doubt a large percentage of people will use mozilla across a remote X.
However, in the society where I currently am, we use old Sparcs as dumb
terminals with a PC actually doing the processing and posting the Sparcs the
graphics so I will keep seeing this. I think this needs investigation and it's
not difficult to test if you have two linux boxes...
(Reporter)

Comment 14

18 years ago
Oops. That should have been a 053120 build...

Comment 15

18 years ago
Not sure who to send this one to.  Anyone have any suggestions.
Created attachment 9556 [details]
stack trace with function symbols, PC/Linux, 5/21
#0  nsBlender::Do8Blend ()                       from libraptorgfx.so
#1  nsBlender::Blend ()                          from libraptorgfx.so
#2  nsBlender::Blend ()                          from libraptorgfx.so
#3  nsBlender::Blend ()                          from libraptorgfx.so
#4  nsViewManager2::RenderDisplayListElement ()  from libraptorview.so
#5  nsViewManager2::RenderViews ()               from libraptorview.so
#6  nsViewManager2::Refresh ()                   from libraptorview.so

dcone@netscape.com is all over cvsblame for nsBlender::Do8Blend, reassigning.
Assignee: asa → dcone

Comment 18

18 years ago
cc: waqar y pavlov
M14 doesn't crash, bug 3/29 already does. Bonsai says there were only two 
changes to nsBlender.cpp in that timeframe, one on 3/15 by dcone@netscape.com,
and one on 3/24 by beard@netscape.com. See

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyAll&branch=HEAD&branchtype=match&dir=&file=nsBlender.cpp&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=02%2F15+&maxdate=03%2F29+&cvsroot=%2Fcvsroot

CC'ing beard@netscape.com. If there is still a nightly for PC/Linux available
from between 3/15 and 3/24, please send me a pointer... 
(Assignee)

Comment 20

18 years ago
The stack trace is identical to 17356, this is a problem in 8 bit or 256 color 
mode with blending.

*** This bug has been marked as a duplicate of 17356 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 21

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr
verified
Status: RESOLVED → VERIFIED

Comment 23

17 years ago
reopening.  the page crashes 2000090608 on win98.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Tried with current build on WIN98 and Linux. Doesn't crash.
resolving as WORKSFORME.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 25

17 years ago
works for me too.
verified again, win98 and linux users on irc
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.