shift+tab doesn't work going from compose body back to subject in both thunderbird and seamonkey

RESOLVED DUPLICATE of bug 390278

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 390278
11 years ago
11 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dbaron-1.9:RpCc])

(Reporter)

Description

11 years ago
version 3.0a1pre (2007071705)
from anywhere in the body...
ctrl+shift+tab works, shift+tab does not.  shift+tab still works between subject and addresses, withind addresses, and going from first address back to body.

shift+tab works in 2.0

Updated

11 years ago
Keywords: regression

Comment 1

11 years ago
This reminds me of bug 387720, but that's supposed to be fixed. Could you figure out a more-definite regression range?
(Reporter)

Comment 2

11 years ago
works
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007062202 SeaMonkey/2.0a1pre
version 3.0a1pre (20070627)

fails
version 3.0a1pre (20070628)
version 3.0a1pre (20070629)

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=caret&product=Core&product=Firefox&product=Mozilla+Application+Suite&product=Thunderbird&product=Toolkit&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&resolution=FIXED&resolution=---&op_sys=All&op_sys=Windows+95&op_sys=Windows+98&op_sys=Windows+ME&op_sys=Windows+NT&op_sys=Windows+2000&op_sys=Windows+XP&op_sys=Windows+Server+2003&op_sys=Windows+Vista&op_sys=Windows+CE&op_sys=Mac+System+7&op_sys=Mac+System+7.5&op_sys=Mac+System+7.6.1&op_sys=Mac+System+8.0&op_sys=Mac+System+8.5&op_sys=Mac+System+8.6&op_sys=Mac+System+9.x&op_sys=Mac+OS+X&op_sys=Linux&op_sys=BSDI&op_sys=FreeBSD&op_sys=NetBSD&op_sys=OpenBSD&op_sys=AIX&op_sys=BeOS&op_sys=HP-UX&op_sys=IRIX&op_sys=Neutrino&op_sys=OpenVMS&op_sys=OS%2F2&op_sys=OSF%2F1&op_sys=SunOS&op_sys=Solaris&op_sys=OpenSolaris&op_sys=Other&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=23d&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
certainly no lack of caret bugs in the last 25 days and the likely culprit bug 237964 fits the regression range, to say it has a ton of regressions is an understatement - including bug 387883[1] arrow keys don't work.  Also seen in seamonkey. Another symptom is caret disappears at times = bug 386872[1]
1. compose
2. tab to subject
3. tab to body
caret disappears

[1]needs to get marked as regression of bug 237964
Blocks: 237964
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: shift+tab doesn't work going from compose body back to subject → shift+tab doesn't work going from compose body back to subject in both thunderbird and seamonkey
This should probably move to "Core: Editor" or something so we can request blocking of 1.9....
Flags: blocking-thunderbird3?
Blocks: 390278

Comment 4

11 years ago
Also reproducible on Linux
OS: Windows XP → All
Hardware: PC → All

Updated

11 years ago
Blocks: 396347
Peter, this is another pain point I run into daily.
Component: Message Compose Window → Editor
Flags: blocking-thunderbird3?
Product: Thunderbird → Core
QA Contact: message-compose → editor
Flags: blocking1.9? → blocking1.9+
Whiteboard: [dbaron-1.9:RpCc]
Peterv's patch for bug 390278 – "Shift+tab no longer navigates out of MIDAS area" fixes this, so I'm marking this as a duplicate of bug 390278.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390278
You need to log in before you can comment on or make changes to this bug.