I get an assert error from gtk in apprunner

RESOLVED FIXED in M12

Status

Core Graveyard
Tracking
P3
normal
RESOLVED FIXED
19 years ago
a year ago

People

(Reporter: Mo DeJong, Assigned: Syd Logan)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When I startup apprunner the browser shows up but after a little
while it prints out an error message in GTK.


Adding menu listener to [Help Contents]
Adding menu listener to [How To Tutorial]
Adding menu listener to [Help Channel]
Adding menu listener to [Software Updates]
Adding menu listener to [Technical Support]
Adding menu listener to [Release Notes]
Adding menu listener to [About Communicator Prototype]

Gtk-CRITICAL **: file gtkbox.c: line 332 (gtk_box_pack_start): assertion
`child->parent == NULL' failed.


After that nothing seems to work.


I was running under Solaris 2.6 on a Sparc box. I compiled with egcs
1.1.1 and I was using glib-1.2.0 and gtk+-1.2.0.

Updated

19 years ago
Assignee: don → pavlov

Comment 1

19 years ago
Re-assigned to pavlov@pavlov.net.

Pavlov, this assert seems to be happening inside GTK (since we don't appear to
have a "gtkbox.c" source file in mozilla.  Any ideas?  Assign back to me if not.

Updated

19 years ago
Severity: major → normal
Status: NEW → ASSIGNED

Comment 2

19 years ago
this is something stupid somewhere.  i'm changing it from major to normal as it
isn't hurting anything.  i've seen it do this on a few other GTK apps, so i
don't think this is mozilla specific.  working to see what is going on.

Updated

19 years ago
QA Contact: 3853
Target Milestone: M4

Comment 3

19 years ago
marking all non-functionality m4 bugs of mine to m5 as i won't be around for the
next week or two.

Updated

19 years ago
Target Milestone: M5 → M6

Comment 4

19 years ago
I think this is a gtk 1.2.0 specific bug as I havn't seen this happening with
more recent version (1.2.[1-2]).  I'm moving it to M6 and going to see if we
can shift to newer versions of gtk slowly as not to upset the peace of things.

Comment 5

19 years ago
*** Bug 5575 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
moving to m7.  to fix this we have to have a new version of GTK.
Target Milestone: M6 → M7

Comment 7

19 years ago
As per bug 5575, this is happening on Linux also.

Updated

19 years ago
QA Contact: gerardok

Comment 8

19 years ago
cyeh: to fix this, i need to require gtk >= 1.2.1

Comment 9

19 years ago
Marking M8.  If you plan to fix any of these for m7, mark them so.

Comment 10

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.

Updated

19 years ago
Assignee: pavlov → pavlov
Status: ASSIGNED → NEW

Updated

19 years ago
Target Milestone: M8 → M12
(Assignee)

Updated

19 years ago
Assignee: pavlov → syd
Status: ASSIGNED → NEW
(Assignee)

Comment 11

19 years ago
Can we get an update on this? Still a problem?

Comment 12

19 years ago
It's not happening on Linux 1999-08-30-01-M10.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
Appears to be fixed by general tree stabilization since the bug was first
reported.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.