If TB does Auto-Dial, first access to IMAP-server fails (DNS-Lookup -> NETBIOS-Lookup)

UNCONFIRMED
Unassigned

Status

MailNews Core
Networking
UNCONFIRMED
11 years ago
3 years ago

People

(Reporter: Achim, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Version 2.0.0.5 (20070716)

I'm a new user of TB and experience a problem with the Windows XP RAS dialer in TB 2.0.0.4 / 2.0.0.5.

In opposite to other networking products, TB's first access to my IMAP server fails, if TB initiates the auto-dial.

In my opinion, the problem lies in the fact, that Windows converts a DNS request to a NETBIOS request, if DNS is not available (-> no connection to internet).

With Microsoft Network Monitor, I tried to trace these actions:

The first I see are three NbtNS-Frames for my mail-provider (http://www.microsoft.com/technet/network/evaluate/technol/tcpipfund/tcpipfund_ch07.mspx "Windows Methods of Resolving Host Names"), which are directed to my PC itself: no network connection at that moment, so they are not resolved.

After these frames are sent without getting an answer, the Windows dialer comes up, I accept the connection parameters, PPPoE frames are sent.

After the PPPoE connection is build up, another DNS request is send, now to the DNS-server of my provider, for de.www.mozilla.com, then, other requests are send to port 80 of www-mozilla-com.glb.mozilla.com and so on.

From now on, everything works.

I verified this behaviour by putting an entry for my mailserver in my (otherwise emtpy) etc/LMHOSTS => now the dialer is called immediately (but TB fails for the next name lookup).

I think, a solution of the TB "connection timeout" when dialing out could be to retry the DNS query after the Windows dialer makes up the connection - maybe no synchronous process, I don't know these things in detail, or instead of first resolving the mail server do a "dummy" connection to some port - better speaking: TB should do the connection of www-mozilla-com.glb.mozilla.com b e f o r e the access / DNS-resolution of the mailserver.

But that are humble thoughts concerning the size of the universe ;-)

Oops, I forgot: you can bypass the error by defining your mail server with the IP-number (in my case 151.189.21.114 instead of IMAP.ARCOR.DE) - uncheck "SSL connection", else, there will be an additional question about the certificate - now, the autodial with TB works, no "connection timed out" msg.

But I think, concerning the problems of specifying IP-addresses, this would be my least opportunity.


Reproducible: Always

Steps to Reproduce:
1. Start TB with no DSL connection (maybe flush DNS cache before)
2. Click OK in WinXP auto-dialer window with correct parameters to setup DSL-connection
3. TB reports that it cannot connect to IMAP-server

Comment 1

9 years ago
Achim, can you reproduce this with beta 3?
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Severity: minor → normal
Component: General → Networking
Product: Thunderbird → MailNews Core
QA Contact: general → networking
Version: unspecified → 1.8 Branch

Updated

9 years ago
Whiteboard: closeme 2009-08-10
(Reporter)

Comment 2

9 years ago
My network config changed since july 2007.
So I tried to reproduce the problem with my actual TB 2.0.0.22:

TB starts, XP PPPoE dialer appears, I click OK, connection established, TB states, that it could not connect to my mail provider, after clicking ok, I can manually retrieve my mail from this point.

Under TB 3 beta 3, behaviour changed:

TB 3b3 starts, TB states, that it could not connect to my mail provider, after clickling ok, TB states, that it could not connect to my mail provider and so on. No XP PPPoE dialer appears.

Netmon shows the same NtbNS frames for both versions except that under TB 2.0.0.22 there are only 3 of this frames but under TB 3b3 there are three after every click on the thunderbird-could-not-connect-popup

Updated

9 years ago
Whiteboard: closeme 2009-08-10

Comment 3

8 years ago
Parkhideh, Achim, is this still true for Thunderbird 3.1?
(Reporter)

Comment 4

8 years ago
TB 3.1.6 says "could not connect to..." but m,eanwhile I reconfigured my whole network (bridged, multiple LAN-cards).  I have to activate the PPPoE-connection explicitly, so the problem doesn't exist for me anymore.
You need to log in before you can comment on or make changes to this bug.