Importing IMAP/POP/SMTP account information from file

RESOLVED DUPLICATE of bug 314744

Status

--
enhancement
RESOLVED DUPLICATE of bug 314744
11 years ago
8 years ago

People

(Reporter: morz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; es-ES; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: 2.0.0.5

Thunderbird lacks a very important feature, which has been present in Outlook (Express) for years: the ability to import/export IMAP/POP/SMTP account configuration from/to a file. The file (maybe XML) could then be used to export the account to another Thunderbird installation, and would be also very useful when supplied by email providers to their users.

Many people do not bother to attempt configuring their email account, and sending them a file with a preset configuration (email address, username, server address, ports, TLS options, ...) has saved me a lot of time. I just want to be able to do that with Thunderbird, too.

Please note that I mean importing/exporting a single account configuration, not all the accounts in Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
ISPs can make such a file... you noticed we shipped Gmail by default?
(Reporter)

Comment 2

11 years ago
That Gmail option is not what I request. First, this is only useful for large email providers like Gmail or Yahoo, that can have their stuff pre-installed in Thunderbird. I do not think that Thunderbird wants to ship with dozens of built-in email provider options.

There is always the possibility of sending a <provider>.rdf file to put in <Mozilla Thunderbird location>\isp\<locale> but that is too cumbersome for the kind of users this is intended for. And if I ship a software to do that automatically, I have to write such a thing for every platform.

Still, as this is not a full account description (but a provider description) they still have to enter their email/account name (and aliases for their email/account name, in the case of more complex setups like mine), and this gives room for errors typing it. Moreover, I do not think that such approach provides support for things like giving names for IMAP folders (Outlook does).

The ideal thing would be a file that can be downloaded from user's account in a provider's web page, save on local disk, and then open it from Thunderbird to create the account. No need for the user to enter their name or anything else, just confirm it.

Comment 3

11 years ago
ISP hooks is really make cool thing but they still have poor documentation and can't control some account parameters.
Give user ability to export account settings in RDF file which is ISP hook compatible, this is simplified life not only for regular user.

Comment 4

11 years ago
Duplicate of bug 242867?
(Reporter)

Comment 5

11 years ago
Functionality described in bug 242867 lacks the configuration export capability mentioned here, and the description of intended functionality is probably a bit more specific here, but otherwise the requested enhancement is the same.

I'm marking this bug as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 242867
(Reporter)

Comment 6

10 years ago
This was considered as a duplicate of bug 242867, but that bug was closed in favor of bug 342242.

Unfortunately, bug 342242 has a completely different proposal, with the following disadvantages:

- Uses DNSSEC, which is not widely deployed and has well-known deployment issues (like DNS root and most TLDs not being signed).

- Requires an effort of DNS coordination when a single e-mail provider wants to deliver automation for accounts under multiple domains, as opposed to providing auto-config for a single (own) domain.

- Forces the user to enter its own data, and hence does not cover the important case where you provide a configuration file with ALL the account's configuration (including e-mail address, IMAP/POP user id, default folder names, and perhaps even password), to prevent users from making mistakes.

I find that the proposal in bug 342242 is far from being equivalent to the proposal in this bug, and also has important deployment issues that prevent considering it as a partial solution to this bug.

Hence, I am re-opening it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

10 years ago
I summarize here my proposal, similar to what posted to the TB newsgroup:

- Configuration is taken from a file. Some ISPs could provide such personalized files (including their own specific data like account ID, etc.) to customers through a secure web page or other means. Other ISPs may just give a generic file without the specific personal data (only ISP-specific data).

- The file is able to provide values for a number of parameters, including:
  a) Main e-mail address and associated Full Name.
  b) Login name.
  c) Password.
  d) Server names for sending/receiving, with the port numbers.
  e) Protocol names for sending/receiving, with TLS options.
  f) Additional identities (name / email aliases) for the main
     e-mail/name identity.
  g) IMAP Folder options 1: specification for default folders found in
     the account. Folder names for sent/draft/spam, etc.
  h) IMAP Folder options 2: individual folder default options for the
     folders in g), including retention policy and keeping a local
     offline copy.
  i) POP inbox retention policy, in case of POP account.

- The file has a recognizable extension and media type, and opens a TB assistant when invoked. If TB finds that the file lacks a required value, such as the password or the login name, asks the user for it. If the file lacks a value that has a default, apply the default instead of asking.

  Host names and protocols are mandatory and must be specified in the file, other fields aren't and either use defaults or ask the user.

- TB should be able to export a single account configuration to such a file.

Comment 8

10 years ago
bug 342242 covers different approach for your solution, but it will still use same file which will be downloaded from server. DNS just point where this file lies, so I assume not big changes we need to accomplish this. If user want this manually do why not.
Status: UNCONFIRMED → NEW
Component: General → Account Manager
Ever confirmed: true
QA Contact: general → account-manager
Version: unspecified → Trunk

Comment 9

10 years ago
marking as depends on bug 342242 - since its more general which cover all autoconfiguration currently.
Depends on: 342242
I wish for this to happen TO in the next version. Please add that possibility.
(Reporter)

Updated

9 years ago
No longer depends on: 342242
(Reporter)

Comment 11

9 years ago
I removed the dependency on bug 342242 as, according to comments on that bug, it is only related to DNS/DNSSec, and is only concerned with a particular use case. Nothing to do with this request.
Status: NEW → RESOLVED
Last Resolved: 11 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314744
(Reporter)

Comment 13

8 years ago
This bug is about individual account information, thus a different level of granularity than bug 314744. Won't bother to reopen, as TB developers obviously do not care about this functionality.
You need to log in before you can comment on or make changes to this bug.