"Assertion failure: *fp->pc == JSOP_CALL || *fp->pc == JSOP_NEW" at flip.com

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jruderman, Assigned: brendan)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Steps to reproduce:
1. Load http://www.flip.com/.

Result:
Assertion failure: *fp->pc == JSOP_CALL || *fp->pc == JSOP_NEW, at mozilla/js/src/jsstr.c:1232

I'm testing with a Mac trunk debug build that has Brendan's patch from bug
385393 comment 97.
(Assignee)

Comment 1

11 years ago
Odd to see bugs filed when the patch involved has not landed, but thanks. I can't get this to crash with the interdiff attached to bug 389331 applied on top of the last patch in bug 385393. Jesse, can you apply and retest?

/be
(Assignee)

Comment 2

11 years ago
Clearly caused by the next-to-last patch in bug 385393.

/be
Assignee: general → brendan
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

11 years ago
Blocks: 385393
(Reporter)

Comment 3

11 years ago
No longer asserts for me with the latest patch there :)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: qawanted
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.