If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla crashed uploading to shutterfly.com [@ 0x00000000] [@ NPUploader.dll]

RESOLVED INVALID

Status

External Software Affecting Firefox
Other
--
critical
RESOLVED INVALID
10 years ago
6 years ago

People

(Reporter: yvette, Assigned: Rick Mann)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

Mozilla crashes whenever I try to upload pictures to my Shutterfly.com account.

Reproducible: Always

Steps to Reproduce:
1.Login to Shutterfly
2.Click the "add pictures" tab
3.Select an album or create a new one (doesn't matter which one it still crashes)
4. Select pictures to upload
5. Click "add selected" button

Actual Results:  
6. Mozilla crashes and closes and I get asked to send an error report to Microsoft.

Expected Results:  
It should have uploaded my selected photos to shutterfly. 

I could do this with no problem before the latest release. I can currently upload with no problem through Internet explorer.
Do you crash with a new profile (http://kb.mozillazine.org/Profile_Manager)
and/or safe mode (http://kb.mozillazine.org/Safe_Mode) ?

Do you have a talkback ID from the crash (http://kb.mozillazine.org/Talkback) ?
Severity: normal → critical
Keywords: crash
Version: unspecified → 2.0 Branch
Works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

I am not able to reproduce this crash with the steps in the description but I did crash after installing the Shutterfly picture uploader plugin, then uninstalling it and then trying to Add pictures. The uninstaller leaves behind some files in the plugins directory (and other places) which Firefox tries to use as the plugin but of course most of it is missing.

yvette: Do you have the plugin installed? If you're not sure go to about:plugins and look for Shutterfly plugin in the list.
Keywords: stackwanted
dupe of bug 240105?  (which is fixed by newer java?)

many crashes on talkback about uploading to shutterfly, so probability seems high these are examples of reporter's issue:
 TB38183616
 TB38183323
and
TB38177791
Stack Signature	 0x00000000 a85bf5a5
Product ID	Firefox2
Build ID	2007102514
Trigger Time	2007-11-17 14:48:15.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	Shutterfly.com
User Comments	up loading pictures
Since Last Crash	513552 sec
Total Uptime	513552 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x00000000
NPUploader.dll + 0xdeb2 (0x0221deb2)
nsObjectFrame::InstantiatePlugin  [mozilla/layout/generic/nsObjectFrame.cpp, line 1366]
nsObjectFrame::Reflow  [mozilla/layout/generic/nsObjectFrame.cpp, line 1239]
nsLineLayout::ReflowFrame  [mozilla/layout/generic/nsLineLayout.cpp, line 996]
nsBlockFrame::ReflowInlineFrame  [mozilla/layout/generic/nsBlockFrame.cpp, line 4247]
nsBlockFrame::DoReflowInlineFrames  [mozilla/layout/generic/nsBlockFrame.cpp, line 3900]
nsBlockFrame::ReflowInlineFrames  [mozilla/layout/generic/nsBlockFrame.cpp, line 3781]
nsBlockFrame::ReflowLine  [mozilla/layout/generic/nsBlockFrame.cpp, line 2774]
nsBlockFrame::ReflowDirtyLines  [mozilla/layout/generic/nsBlockFrame.cpp, line 2304]
nsBlockFrame::Reflow  [mozilla/layout/generic/nsBlockFrame.cpp, line 906]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsTableCellFrame::Reflow  [mozilla/layout/tables/nsTableCellFrame.cpp, line 858]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsTableRowFrame::ReflowChildren  [mozilla/layout/tables/nsTableRowFrame.cpp, line 964]
nsTableRowFrame::Reflow  [mozilla/layout/tables/nsTableRowFrame.cpp, line 1418]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsTableRowGroupFrame::ReflowChildren  [mozilla/layout/tables/nsTableRowGroupFrame.cpp, line 400]
nsTableRowGroupFrame::Reflow  [mozilla/layout/tables/nsTableRowGroupFrame.cpp, line 1258]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsTableFrame::ReflowChildren  [mozilla/layout/tables/nsTableFrame.cpp, line 3293]
nsTableFrame::Reflow  [mozilla/layout/tables/nsTableFrame.cpp, line 1948]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsTableOuterFrame::OuterReflowChild  [mozilla/layout/tables/nsTableOuterFrame.cpp, line 1320]
nsTableOuterFrame::Reflow  [mozilla/layout/tables/nsTableOuterFrame.cpp, line 1965]
nsBlockReflowContext::ReflowBlock  [mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [mozilla/layout/generic/nsBlockFrame.cpp, line 3494]
nsBlockFrame::ReflowLine  [mozilla/layout/generic/nsBlockFrame.cpp, line 2653]
nsBlockFrame::ReflowDirtyLines  [mozilla/layout/generic/nsBlockFrame.cpp, line 2304]
nsBlockFrame::Reflow  [mozilla/layout/generic/nsBlockFrame.cpp, line 906]
nsBlockReflowContext::ReflowBlock  [mozilla/layout/generic/nsBlockReflowContext.cpp, line 606]
nsBlockFrame::ReflowBlockFrame  [mozilla/layout/generic/nsBlockFrame.cpp, line 3494]
nsBlockFrame::ReflowLine  [mozilla/layout/generic/nsBlockFrame.cpp, line 2653]
nsBlockFrame::ReflowDirtyLines  [mozilla/layout/generic/nsBlockFrame.cpp, line 2304]
nsBlockFrame::Reflow  [mozilla/layout/generic/nsBlockFrame.cpp, line 906]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
CanvasFrame::Reflow  [mozilla/layout/generic/nsHTMLFrame.cpp, line 536]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
nsHTMLScrollFrame::ReflowScrolledFrame  [mozilla/layout/generic/nsGfxScrollFrame.cpp, line 523]
nsHTMLScrollFrame::ReflowContents  [mozilla/layout/generic/nsGfxScrollFrame.cpp, line 571]
nsHTMLScrollFrame::Reflow  [mozilla/layout/generic/nsGfxScrollFrame.cpp, line 769]
nsContainerFrame::ReflowChild  [mozilla/layout/generic/nsContainerFrame.cpp, line 909]
ViewportFrame::Reflow  [mozilla/layout/generic/nsViewportFrame.cpp, line 240]
IncrementalReflow::Dispatch  [mozilla/layout/base/nsPresShell.cpp, line 915]
PresShell::ProcessReflowCommands  [mozilla/layout/base/nsPresShell.cpp, line 7068]
ReflowEvent::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6894]
PL_HandleEvent  [mozilla/xpcom/threads/plevent.c, line 689]
0x778b0c24
0x0020006c
0x558d00b4
Summary: mozilla crashed → mozilla crashed uploading to shutterfly.com [@ 0x00000000] [@ NPUploader.dll]
Yvette, do you still see this problem?

(note: 0x00000000 is a topcrash)
Keywords: stackwanted
0x00000000 is just a null pointer. NPUploader.dll isn't part of the smart analysis for the 0x00000000 crashes, so it's not a topcrash.

This is almost certainly caused by the Shutterfly picture uploader add-on/plugin.

This should probably be closed INVALID unless someone can prove that Firefox is at fault here.
Never used smart analysis before. I have no doubt it's caused by the plugin, but thought that FF should perhaps not crash regardless.  

Hopefully Yvette will respond.  Yvette, do any of these items below help?

- conflict with Powermarks and WebResearch addons http://64.233.169.104/search?q=cache:VBdQXxv_yioJ:forums.mozillazine.org/viewtopic.php%3Fp%3D2765370+shutterfly+firefox+plugin+crash&hl=en&ct=clnk&cd=4&gl=us&lr=lang_en&client=firefox-a
- conflict with google toolbar http://groups.google.com/group/FFToolbar-group-advanced/browse_thread/thread/c9d9615f0aa03377

Updated

10 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 2.0 Branch → 1.8 Branch
(Reporter)

Comment 7

10 years ago
I tried removing and/or disabling any plug-ins and extensions I have but that does not help. I also have updated to the latest version of Java but I still get the crash when trying to upload. In fact, now it crashes sooner in the process. Before I could select the photos but now it crashes before I select any photos, right after I select an album to upload to.

(In reply to comment #6)
> Never used smart analysis before. I have no doubt it's caused by the plugin,
> but thought that FF should perhaps not crash regardless.  
> 
> Hopefully Yvette will respond.  Yvette, do any of these items below help?
> 
> - conflict with Powermarks and WebResearch addons
> http://64.233.169.104/search?q=cache:VBdQXxv_yioJ:forums.mozillazine.org/viewtopic.php%3Fp%3D2765370+shutterfly+firefox+plugin+crash&hl=en&ct=clnk&cd=4&gl=us&lr=lang_en&client=firefox-a
> - conflict with google toolbar
> http://groups.google.com/group/FFToolbar-group-advanced/browse_thread/thread/c9d9615f0aa03377
> 

Duplicate of this bug: 411182
This is clearly caused by the plugin that comes with shuterfly "NPUploader.dll" and that firefox should not crash is not an option because plugins are running in the same process as Firefox and Firefox can't survive a crash of the plugin Thread.

We do have an enhancement request bug that Plugins should run in it's own process
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Assignee: nobody → rmann

Updated

8 years ago
Component: Plug-ins → Other
Product: Core → Plugins
QA Contact: plugins → other
Version: 1.8 Branch → unspecified
Crash Signature: [@ 0x00000000] [@ NPUploader.dll]
You need to log in before you can comment on or make changes to this bug.