lines appear in images if you scroll the page while they're still loading, and layout.css.dpi is greater than or equal to 144

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: db48x, Assigned: sharparrow1)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
These lines can be both horizontal and vertical, depending on which direction you scroll the page. I have layout.css.dpi set to 144, and the black lines are two pixels wide. When I set it to 240, the lines are 3 pixels wide. They cover only the image(s) that are loading, not the rest of the page. Once the image is fully loaded, these lines no longer occur while scrolling, though any existing lines remain on the screen until that part of the image is forced to redraw, for example by being scrolled off screen and back.

I tried to take a screenshot of this, but that caused the window to be redrawn and the lines to disappear.
(Reporter)

Comment 1

11 years ago
Oh, and I'm the trunk, build id is not too old at 2007072116
(Reporter)

Comment 2

11 years ago
Ah, and the color of the line is the background color, it's not always black. Try doing view image on that page, and you'll get white lines.
Summary: black lines appear in images if you scroll the page while they're still loading, and layout.css.dpi is greater than or equal to 144 → lines appear in images if you scroll the page while they're still loading, and layout.css.dpi is greater than or equal to 144
(Assignee)

Comment 3

11 years ago
Created attachment 274021 [details] [diff] [review]
Patch

The arithmetic here is just weird; do something sane-looking.
Assignee: nobody → sharparrow1
Status: NEW → ASSIGNED
Attachment #274021 - Flags: review?(vladimir)
Comment on attachment 274021 [details] [diff] [review]
Patch

This looks good, though I'd ping dbaron since he put that code in initially, and i'm not sure why now.  But it might have been a thinko.
Attachment #274021 - Flags: review?(vladimir) → review+
(Assignee)

Comment 5

11 years ago
It's not dbaron's code; see Bug 337424.
(Reporter)

Comment 6

11 years ago
You could take out the comment too.
(Assignee)

Comment 7

11 years ago
I'll do that when I check in.
(Assignee)

Comment 8

11 years ago
Comment on attachment 274021 [details] [diff] [review]
Patch

Fix for a minor bug in painting scaled images while they are loading.  Extremely low-risk; the worst possible side-effect is a rounding error painting images while loading.
Attachment #274021 - Flags: approval1.9?
(Assignee)

Updated

11 years ago
Component: Layout: Images → GFX: Thebes
QA Contact: layout.images → thebes
Comment on attachment 274021 [details] [diff] [review]
Patch

a19=dbaron
Attachment #274021 - Flags: approval1.9? → approval1.9+
Duplicate of this bug: 376181
(Assignee)

Comment 11

11 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.