ActionMonkey build fails: ‘class MMgc::RCObject’ has no member named ‘DecrementRef’

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Anthony Nemitz, Assigned: jorendorff)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: Trunk

After applying the patch for bug 389443, the build system fails: In destructor ‘MMgc::WriteBarrierRC<T>::~WriteBarrierRC()’:
/home/anemitz/actionmonkey/js/tamarin/MMgc/WriteBarrier.h:150: error: ‘class MMgc::RCObject’ has no member named ‘DecrementRef’


Reproducible: Always

Steps to Reproduce:
1. Apply patch for 389443
2. make -f Makefile.ref 

Actual Results:  
g++ -o MMgc/MMgc.o -DSOFT_ASSERTS  -DDEBUG -D_DEBUG   -fno-exceptions -fno-rtti -Werror -Wall -Wno-reorder -Wno-switch -Wno-invalid-offsetof -fmessage-length=0 -finline-functions -finline-limit=65536  -g    -I/home/anemitz/actionmonkey/js/tamarin -I/home/anemitz/actionmonkey/js/tamarin/MMGC -I/home/anemitz/actionmonkey/js/tamarin/core -I/home/anemitz/actionmonkey/js/tamarin/codegen -I/home/anemitz/actionmonkey/js/tamarin/pcre  -c MMgc/MMgc.ii
/home/anemitz/actionmonkey/js/tamarin/MMgc/WriteBarrier.h: In destructor ‘MMgc::WriteBarrierRC<T>::~WriteBarrierRC()’:
/home/anemitz/actionmonkey/js/tamarin/MMgc/WriteBarrier.h:150: error: ‘class MMgc::RCObject’ has no member named ‘DecrementRef’
(Reporter)

Updated

11 years ago
Summary: ActionMonkey build system fails: ‘class MMgc::RCObject’ has no member named ‘DecrementRef’ → ActionMonkey build fails: ‘class MMgc::RCObject’ has no member named ‘DecrementRef’
(Assignee)

Comment 1

11 years ago
anemitz reports that hacking the Makefile to add -DUNIX -DAVMPLUS_UNIX gets him past this problem.

These flags need to be added in 3 places:

1. js/tamarin/configure.py or one of the python scripts in js/tamarin/build

2. js/src/config/Linux_All.mk (the easy one) - see dup bug 389749 to see why we need to add these flags here as well

3. Makefile.in, for the same reason as #2 (bsmedberg?)

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

11 years ago
Duplicate of this bug: 389749
(Reporter)

Comment 3

11 years ago
Created attachment 274176 [details] [diff] [review]
js/tamarin/configure.py - added check for linux
(Reporter)

Comment 4

11 years ago
Created attachment 274178 [details] [diff] [review]
js/src/config/Linux_All.mk fix - added unix flags
(Assignee)

Updated

11 years ago
Attachment #274176 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #274178 - Flags: review+
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
(Assignee)

Comment 5

11 years ago
This is happening again for both Swaroop and Anthony.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

11 years ago
Created attachment 280344 [details] [diff] [review]
trivial fix for linux build

I think a merge from upstream broke this.  The fix is trivial.  Pushed to actionmonkey branch, changeset f851780ab3d8.
Assignee: general → jorendorff
Status: REOPENED → ASSIGNED
Attachment #280344 - Flags: review+
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.