If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

location bar could treat "/", "." and "&" as word separators, to improve functioning of Ctrl-arrows and Ctrl+Delete

RESOLVED DUPLICATE of bug 190615

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 190615
10 years ago
10 years ago

People

(Reporter: Krzysztof Foltman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)

In Windows version of Firefox, I can use Ctrl-Backspace in order to remove parts of the URL. In Linux version, chars like "/" are not treated as word separators, so Ctrl+Backspace removes everything up to the beginning of the line, and Ctrl+arrows work just like Home/End.

It would be nice if the Linux behaviour followed the Windows behaviour, as it is rather handy in correcting mistyped URLs or changing URL parameters.

This may be considered low priority as it's mainly a feature for advanced users, but it affects browsing comfort nevertheless.

Reproducible: Always

Steps to Reproduce:
1. Type a complex (but valid - no spaces etc) URL in the location bar (say, https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&format=guided)
2. Press Ctrl-left a few times, then Ctrl-right a few times, and observe the behaviour
3. Do the same in the Windows version, and compare the behaviour to Linux version
4. Do the same with Ctrl-backspace shortcut
Actual Results:  
Ctrl-left instead of moving the caret one URL part to the left (subdomain, parameter etc), double-acts as Home
Ctrl-right double-acts as End


Expected Results:  
Starting from the end and pressing Ctrl-left several time, the sequence of caret stops should be "guided", "format", "Firefox", "product", "cgi", "enter_bug", "org", "mozilla", "bugzilla", "https".
(Reporter)

Comment 1

10 years ago
By the way, I forgot about "=" as a potential candidate for inclusion in word separator character list.
(Reporter)

Comment 2

10 years ago
Looks like it can be turned on by setting

layout.word_select.stop_at_punctuation

in about:config - still, it looks like it would make sense to make it separate settings for the location bar and the content pane.

The double-clicking behaviour in content pane and Ctrl-navigation in location bar seem to be different enough not to use the same settings.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 190615
You need to log in before you can comment on or make changes to this bug.