Closed Bug 389529 Opened 17 years ago Closed 17 years ago

Buttons mometarily revert to unstyled form when clicked

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 375436

People

(Reporter: mossop, Assigned: jaas)

Details

I've noticed this ever since OS styled buttons landed in webpages but couldn't find a dupe anywhere.

Basically when you click on a button, just for a moment it gets drawn as it used to (grey rectangle box) complete with dotted focus outline in the middle. Then it gets drawn as a properly pressed and focused OS button.

This only happens if the button is unfocused when you press it, but in that case it does appear to happen everytime. I can easily reproduce with the "Add an attachment" button on this form.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007072404 Minefield/3.0a7pre ID:2007072404
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.