Operator not compatible with Flock 0.9.0.1

VERIFIED FIXED

Status

Mozilla Labs
Operator
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Douglas Greenshields, Assigned: mkaply)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070719 Firefox/2.0.0.5 Flock/0.9.0.1
Build Identifier: Operator: 0.7, 0.8b  Flock: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070719 Firefox/2.0.0.5 Flock/0.9.0.1

Operator 0.7 will install on versions of Flock that identify themselves as <=0.9. 0.8b will install on versions <=0.8 (although Flock versioning skipped the 0.8 number). Would like to install Operator on the latest release (of course, assuming it's been tested adequately on it).

Reproducible: Always

Steps to Reproduce:
1. Try and install Operator.
2.
3.
Actual Results:  
Install complained that the extension was only compatible with earlier versions of Flock.

Expected Results:  
Assuming the developer can be sure that it would work on the current release version, it should have installed.
(Assignee)

Comment 1

10 years ago
I updated Operator 0.7 on addons yesterday. 0.8 hasn't been updated yet.

Have you tested the latest version?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> I updated Operator 0.7 on addons yesterday. 0.8 hasn't been updated yet.
> Have you tested the latest version?

It was the version on addons with the date July 23, 2007, so I assume yes.  I've tried again within the last few minutes, with the same result.
(Assignee)

Comment 3

10 years ago
Argh. I used 0.9 instead of 0.9.0.*.

I've fixed this in SVN. operator 0.8 will be RSN, and this will be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

10 years ago
Flock 0.9.0.2 allows Operator version 0.8 (from addons) to install.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.