Crash when loading jpeg image with utf-8 set as default charset [@ 0x94298df] [@ nsStyleContext::Destroy]

RESOLVED DUPLICATE of bug 389663

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 389663
11 years ago
7 years ago

People

(Reporter: Oliver Saier, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007072604 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007072604 Minefield/3.0a7pre (ubuntu-feisty)

Plz see URL above. Always crashes for me.

Crash ID: bp-46d3eef0-3bbf-11dc-bd54-001a4bd46e84
You can view details of this crash at http://crash-stats.mozilla.com/report/index/46d3eef0-3bbf-11dc-bd54-001a4bd46e84?date=2007-07-26-21

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
Dupe of bug 389663 per stacktrace.

0  	@0x94298df
1 	nsStyleContext::Destroy()
2 	nsStyleContext::Release()
3 	nsRefPtr<nsStyleContext>::~nsRefPtr()
4 	nsImageDocument::CheckOverflowing(int)
5 	nsImageDocument::OnStartContainer(imgIRequest*, imgIContainer*)
6 	nsImageLoadingContent::OnStartContainer(imgIRequest*, imgIContainer*)
7 	imgRequestProxy::OnStartContainer(imgIContainer*)
8 	imgRequest::OnStartContainer(imgIRequest*, imgIContainer*)
9 	nsJPEGDecoder::WriteFrom(nsIInputStream*, unsigned int, unsigned int*)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: Crash when loading jpeg image with utf-8 set as default charset → Crash when loading jpeg image with utf-8 set as default charset [@ 0x94298df] [@ nsStyleContext::Destroy]
Duplicate of bug: 389663
(Assignee)

Updated

7 years ago
Crash Signature: [@ 0x94298df] [@ nsStyleContext::Destroy]
You need to log in before you can comment on or make changes to this bug.