ActionMonkey: Linux build: 'class MMgc::RCObject' has no member named 'DecrementRef'

RESOLVED DUPLICATE of bug 389507

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 389507
11 years ago
2 months ago

People

(Reporter: jorendorff, Unassigned)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Reported by oc2k1:

oc2k1@localhost ~/actionmonkey $ cd js/src; make -f Makefile.ref
cat: ../../dist/Linux_All_DBG.OBJ/nspr/Version: No such file or directory
cd editline; make -f Makefile.ref all
make[1]: Entering directory `/home/oc2k1/actionmonkey/js/src/editline'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/oc2k1/actionmonkey/js/src/editline'
make -f Makefile.ref  Linux_All_DBG.OBJ/libjs.a Linux_All_DBG.OBJ/libjs.so Linux_All_DBG.OBJ/js  Linux_All_DBG.OBJ/jsautocfg.h Linux_All_DBG.OBJ/jscpucfg Linux_All_DBG.OBJ/jscpucfg.o
cat: ../../dist/Linux_All_DBG.OBJ/nspr/Version: No such file or directory
make[1]: Entering directory `/home/oc2k1/actionmonkey/js/src'
make[1]: Circular jscpucfg.h <- Linux_All_DBG.OBJ/jsautocfg.h dependency dropped.
make[1]: Circular Linux_All_DBG.OBJ/jsautocfg.h <- Linux_All_DBG.OBJ/jsautocfg.h dependency dropped.
g++ -o Linux_All_DBG.OBJ/jsapi.o -c -Wall -Wno-format -MMD -fno-rtti -DGCC_OPT_BUG -g -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R -DUSE_MMAP -DX86_LINUX  -DDEBUG -DDEBUG_oc2k1 -DSOFT_ASSERTS -D__DEBUGGING__ -DEDITLINE -ILinux_All_DBG.OBJ -I../tamarin/MMgc  jsapi.cpp
In file included from ../tamarin/MMgc/MMgc.h:128,
                from jscntxt.h:59,
                from jsapi.cpp:59:
../tamarin/MMgc/WriteBarrier.h: In destructor `MMgc::WriteBarrierRC<T>::~WriteBarrierRC()':
../tamarin/MMgc/WriteBarrier.h:150: error: 'class MMgc::RCObject' has no member named 'DecrementRef'
make[1]: *** [Linux_All_DBG.OBJ/jsapi.o] Error 1
make[1]: Leaving directory `/home/oc2k1/actionmonkey/js/src'
make: *** [all] Error 2

Patches welcome-- I have no idea what's causing this and don't have a Linux box or VM handy.
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389507

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.