Dual Display Causes Bookmark Toolbar Dropdown Menus to display on the wrong display once window moved

RESOLVED DUPLICATE of bug 389365

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 389365
11 years ago
11 years ago

People

(Reporter: Adam Smith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

First: My Macbook Pro moves between home and the office so is frequently changed between Dual-Head Display and Single.  So:

When launching a new Firefox window it will usually load up on the primary display (the one with the menu bar and dock.)  If I drag the window over to the secondary display, as soon as I click on any dropdown menus on my Bookmarks toolbar, the submenu displays on the primary display instead of the secondary one (ie the FF window is on Display2 and the dropdown menu part displays on the OTHER screen.)

I can fix this by quitting Firefox while the window is displayed on the secondary display and then relaunching it.  This will cause Firefox to relaunch on the secondary display and my Bookmark dropdowns will now work properly.

My primary display is the external monitor and my secondary display is the MacBook Pro screen.

Reproducible: Always

Steps to Reproduce:
1. Run MacBook Pro in single (no attached monitor) display.
2. Launch Firefox
3. Quit Firefox
4. Attach additional monitor
5. Launch Firefox
6. Drag the Firefox window over to the second monitor
7. Click on any Bookmark Toolbar dropdown menus
(They will display on the wrong screen)

8. Quit Firefox
9. Relaunch Firefox
10. Click on a Bookmark Toolbar menu
(They will display on the correct screen)
Actual Results:  
Displayed the bookmark menu on the screen that Firefox was launched from, not the screen Firefox is displayed on.

Expected Results:  
The dropdown bookmark menus should have displayed on the screen in which Firefox's main window was on.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389365
You need to log in before you can comment on or make changes to this bug.