easily provisioned Mercurial repositories for branches

RESOLVED DUPLICATE of bug 388332

Status

mozilla.org Graveyard
Server Operations
RESOLVED DUPLICATE of bug 388332
11 years ago
3 years ago

People

(Reporter: db48x, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Because the preferred way to branch a Mercurial repository is to create a local clone of it, collaboration on that branch between several people requires that at least one of the collaborators have a setup that makes sharing the branch easy. This requires a computer that is always on, with a reasonably reliable internet service either a fixed ip address or a dynamic dns service (though this can be had for free), and frequently the ability to forward a port through a consumer router.

Since not every one meets those requirements, I think it would be useful to have a server that contributors could use to create a new repository on, cloned from an existing repository. They would then be able to push changes to it to make them public. The best solution would be completely automated, or very nearly so. This would be similar to the service offered by landfill.bugzilla.org, where a bugzilla contributor can quickly and easily set up new instances of the bugzilla software to test and demonstrate a new feature or bug fix. The main difference would be that nobody need receive shell access to the machine.

Last night I whipped up a simple perl script to do this. You can go to http://db48x.net/.hglandfill/create_new.html to add a new repsitory, and http://db48x.net/.hglandfill/ will show you a list of the repositories.

This script has several limitations, the primary one being that I can't enable anyone to push to the repositories they create, because to do that requires that I use <Location> directives in the apache configuration, and that's not something I can do on a shared web host. Also, I'd want to rewrite it in Python so that it can use the Mercurial libraries directly, rather than executing them in a subshell. It would also mean less worry about someone hijacking that shell invocation (pretty sure I did it correctly though). It would also be able to offer better feedback during the creation process than the current script.
Dupe of bug 388332, but both contain a ton of info.
(Reporter)

Comment 2

11 years ago
Yea, I thought I couldn't have been the first to think of it. Guess I overlooked it when I searched.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388332
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.