HTTP auth. doesn't work correctly on trunk.stage.m.c

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: Adam Guthrie, Assigned: oremj)

Tracking

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072605 Minefield/3.0a7pre

Steps to reproduce:
1. Go to https://www.trunk.stage.mozilla.com/en-US/press/.

Actual results:
I get an HTTP auth. dialog, but the page still loads in the background. When I click cancel, I can view the page fine.

Expected results:
I'm not allowed to see the page's content until I authenticate.
Assignee: nobody → server-ops
Component: www.mozilla.com → Server Operations
OS: Windows XP → All
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → justin
Hardware: PC → All
Version: unspecified → other
(Assignee)

Updated

11 years ago
Assignee: server-ops → oremj
I'm unable to reproduce this.  When I go there, I'm prompted for a username/password.  If I click "cancel" I'm given the standard 401 error page.

FF 2.0.0.4 on linux.
(Assignee)

Comment 2

11 years ago
I also can not reproduce.  I have tried this with FF 2.0.0.(4|5) win/osx/linux.
(Assignee)

Comment 3

11 years ago
Reed mentioned he made a couple changes.  Assuming this is fixed.  Please reopen if the problem still exists.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

11 years ago
Yep, looks like whatever he did fixed this. Sorry for the trouble. (I was testing using a Win32 trunk build, FWIW.)
Status: RESOLVED → VERIFIED
This is still broken. I was able to load a page from the stage site without logging in.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

11 years ago
Which page?  Did you get any other information? Do you think this has to do with browser cache?  It is very possibly a netscaler cache issue.
(Assignee)

Comment 7

11 years ago
Any idea how to consistently reproduce this?
(Assignee)

Comment 8

11 years ago
Set cache-control: private that should fix the problem.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.